Bug 245073 - Problem with openssl-1.1.1e after update in base system
Summary: Problem with openssl-1.1.1e after update in base system
Status: New
Alias: None
Product: Base System
Classification: Unclassified
Component: gnu (show other bugs)
Version: 12.1-STABLE
Hardware: amd64 Any
: --- Affects Many People
Assignee: freebsd-bugs mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-03-26 12:23 UTC by iron.udjin
Modified: 2020-03-26 12:23 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description iron.udjin 2020-03-26 12:23:30 UTC
Hello,

I'm running: 12.1-STABLE r359193

Recently openssl in the base system of 12-STABLE was updated up to 1.1.1e. When I run:

# php --run 'file_get_contents("https://google.com");'

I'm getting error:
Warning: file_get_contents(): SSL operation failed with code 1. OpenSSL Error messages:
error:14095126:SSL routines:ssl3_read_n:unexpected eof while reading in Command line code on line 1

Here is issue and solution: https://github.com/openssl/openssl/pull/11400

I've tested reverted patch on port version openssl and it solves my issue. Please commit this patch to the base system. I guess it affects all people who use -STABLE tree.

Thank you!