Bug 245237 - ftp/curl: 7.69.1 broken when c-ares is used
Summary: ftp/curl: 7.69.1 broken when c-ares is used
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Sunpoet Po-Chuan Hsieh
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-04-01 15:26 UTC by Michael Osipov
Modified: 2020-04-02 12:25 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (sunpoet)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Osipov 2020-04-01 15:26:59 UTC
Curl starts telling me:

> $ git pull
> warning: curl_multi_add_handle failed: Invalid easy handle
> fatal: konnte nicht auf 'https://gitbox.apache.org/repos/asf/maven.git/' zugreifen: failed to start HTTP request

This is the cause: https://github.com/curl/curl/issues/5097

Recompiling with the threaded resolver makes it work again. Here is a fix (https://github.com/curl/curl/commit/3bfda07004a5739fb306e55cb9529ba3de35fbdb) which can be applied until 7.69.2 is out.
Comment 1 Sunpoet Po-Chuan Hsieh freebsd_committer 2020-04-02 12:23:47 UTC
Committed. Thanks!
Comment 2 commit-hook freebsd_committer 2020-04-02 12:25:14 UTC
A commit references this bug:

Author: sunpoet
Date: Thu Apr  2 12:23:36 UTC 2020
New revision: 530365
URL: https://svnweb.freebsd.org/changeset/ports/530365

Log:
  Fix runtime error (for CARES enabled and IPV6 disabled builds)

  - Bump PORTREVISION for package change

  Obtained from:	https://github.com/curl/curl/commit/3bfda07004a5739fb306e55cb9529ba3de35fbdb
  PR:		245237
  Reported by:	Michael Osipov <michael.osipov@siemens.com>

Changes:
  head/ftp/curl/Makefile
  head/ftp/curl/files/patch-lib-easy.c