Bug 245395 - emulators/emu64: Main emulator window doesn't show
Summary: emulators/emu64: Main emulator window doesn't show
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: amd64 Any
: --- Affects Only Me
Assignee: Rodrigo Osorio
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-04-06 11:41 UTC by Ingo
Modified: 2020-06-10 04:30 UTC (History)
4 users (show)

See Also:
felix: maintainer-feedback+
koobs: merge-quarterly+


Attachments
Logfile from emu64 (3.00 KB, text/plain)
2020-04-07 16:01 UTC, Ingo
no flags Details
fix audio fragment size for OSS (1.29 KB, patch)
2020-04-11 10:46 UTC, Felix Palmen
felix: maintainer-approval+
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Ingo 2020-04-06 11:41:14 UTC
On FreeBSD 12.1-RELEASE amd64 Openbox: Starting emu64 doesn't show the main emulator windows. The windows for choosing disk drives and disk images is visible and seems to work.
There are no error messages in dmesg, Xorg.0.log or emu64.log. Building the port or installing the package is also the same.
Comment 1 Felix Palmen 2020-04-06 11:48:59 UTC
Hello Ingo,

I will probably ask upstream for help with that, but first, could you please show the output of

    xwininfo -root -tree | grep emu64

while emu64 is running? Thanks!
Comment 2 Ingo 2020-04-06 21:19:26 UTC
This is the output:


ingo@merope:~ % xwininfo -root -tree | grep emu64
     0x1a00006 "emu64": ("emu64" "emu64")  400x400+760+340  +760+340
     0x1a00004 "Qt Selection Owner for emu64": ()  3x3+0+0  +0+0
        0x1a0000f "Emu64 Version 5.0.18 --- [FreeBSD 64Bit]": ("emu64" "emu64")  482x204+2+25  +719+417
Comment 3 Felix Palmen 2020-04-07 07:17:25 UTC
(In reply to Ingo from comment #2)

Thanks, this was just to make sure the window is indeed missing and not just invisible/unmapped. I now created an upstream issue (in german) here:

https://github.com/ThKattanek/emu64/issues/192

I guess a full listing of ~/.config/emu64/emu64.log might help identify the problem, could you please add it (here or to the upstream issue)?
Comment 4 Kubilay Kocak freebsd_committer freebsd_triage 2020-04-07 08:40:45 UTC
^Triage: Leave maintainer-feedback open pending upstream issue resolution
Comment 5 Ingo 2020-04-07 16:01:27 UTC
Created attachment 213158 [details]
Logfile from emu64

This is the logfile from emu64. Before starting emu64, I deleted the ~/.config/emu64 to have a "fresh" logfile.
Comment 6 Felix Palmen 2020-04-07 22:30:57 UTC
(In reply to Ingo from comment #5)

Ingo, please have a look at the upstream issue and reply there directly. It seems the upstream author already has some idea what's wrong and I can't do more than copy stuff around and translate, so that's probably unnecessary :) Of course I will follow this PR as well as the upstream issue and add a patch here as soon as that seems possible!

Thanks and BR,
Felix
Comment 7 Felix Palmen 2020-04-11 10:46:59 UTC
Created attachment 213276 [details]
fix audio fragment size for OSS

Could you please test the port with the attached patch?

Background: In the upstream issue, it was revealed that the whole C64 emulation depends on the audio stream (for best sync) and initializing the audio stream failed when the SDL backend was OSS, because it needs a fragment size that is a power of two. The attached patch is the minimal change to 5.0.18 from the upstream commit that solved the problem.
Comment 8 Ingo 2020-04-11 12:42:39 UTC
The new port works now for me.
Comment 9 Felix Palmen 2020-04-17 06:44:01 UTC
The fix was also confirmed by the upstream author, testing on GhostBSD.
Comment 10 commit-hook freebsd_committer 2020-04-19 09:06:46 UTC
A commit references this bug:

Author: rodrigo
Date: Sun Apr 19 09:05:48 UTC 2020
New revision: 532092
URL: https://svnweb.freebsd.org/changeset/ports/532092

Log:
  emulators/emu64: extend patch to fix an issue with OSS

  This update is require to unbreak the port under FreeBSD.
  The issue was reported to upstream and the fix will be available in future
  releases.

  Background: In the upstream issue, it was revealed that the whole C64 emulation
  depends on the audio stream (for best sync) and initializing the audio stream
  failed when the SDL backend was OSS, because it needs a fragment size that is a
  power of two. The attached patch is the minimal change to 5.0.18 from the
  upstream commit that solved the problem.

  PR:		245395
  Submitted by:	Ingo <hylaios@online.de>
  Approved by:	Felix Palmen <felix@palmen-it.de> (maintainer)
  MFH:		2020Q2

Changes:
  head/emulators/emu64/Makefile
  head/emulators/emu64/files/patch-src_c64__class.cpp
Comment 11 Rodrigo Osorio freebsd_committer 2020-04-19 09:08:23 UTC
Committed, thanks. I request and MFC to make this fix available for peoples using the quarter branch of ports.
Comment 12 commit-hook freebsd_committer 2020-04-19 17:21:39 UTC
A commit references this bug:

Author: rodrigo
Date: Sun Apr 19 17:21:08 UTC 2020
New revision: 532136
URL: https://svnweb.freebsd.org/changeset/ports/532136

Log:
  MFH: r532092

  emulators/emu64: extend patch to fix an issue with OSS

  This update is require to unbreak the port under FreeBSD.
  The issue was reported to upstream and the fix will be available in future
  releases.

  Background: In the upstream issue, it was revealed that the whole C64 emulation
  depends on the audio stream (for best sync) and initializing the audio stream
  failed when the SDL backend was OSS, because it needs a fragment size that is a
  power of two. The attached patch is the minimal change to 5.0.18 from the
  upstream commit that solved the problem.

  PR:		245395
  Submitted by:	Ingo <hylaios@online.de>
  Approved by:	Felix Palmen <felix@palmen-it.de> (maintainer)

  Approved by:	ports-secteam@

Changes:
_U  branches/2020Q2/
  branches/2020Q2/emulators/emu64/Makefile
  branches/2020Q2/emulators/emu64/files/patch-src_c64__class.cpp
Comment 13 Kubilay Kocak freebsd_committer freebsd_triage 2020-06-10 04:30:28 UTC
^Triage: Track merge to quarterly