Bug 245519 - graphics/gimp: relies on graphics/py-gimp and Python 2.7
Summary: graphics/gimp: relies on graphics/py-gimp and Python 2.7
Status: Closed Overcome By Events
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: freebsd-gnome (Nobody)
URL:
Keywords:
: 249696 (view as bug list)
Depends on:
Blocks: 249337
  Show dependency treegraph
 
Reported: 2020-04-10 21:06 UTC by Andy Mender
Modified: 2020-09-29 19:14 UTC (History)
2 users (show)

See Also:
bugzilla: maintainer-feedback? (gnome)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andy Mender 2020-04-10 21:06:58 UTC
graphics/gimp has Python support ON by default. This pulls in graphics/py-gimp which is a rather old port and requires Python 2.7 explicitly. From the Makefile for graphics/py-gimp:
DEPRECATED=	Uses deprecated version of python
EXPIRATION_DATE=	2020-08-15

GIMP_SLAVE=	pygimp

USES=		python:2.7
USE_GNOME=	pygtk2

The Fedora community has a similar problem, just before their 32 release: https://bugzilla.redhat.com/show_bug.cgi?id=1737933

GIMP3 is in the making and it *should* default to Python3, however no info is available on the official Roadmap: https://wiki.gimp.org/wiki/Roadmap#GIMP_3.0

I can start tinkering with GIMP3 to see whether it's possible to re-use the current Makefile, but that would still provide a "gimp-devel" port at best.

The alternative would be to disable Python support in graphics/gimp so that the port continues building past its expiration date.
Comment 1 Steve Wills freebsd_committer 2020-09-24 17:10:25 UTC
*** Bug 249696 has been marked as a duplicate of this bug. ***
Comment 2 Rene Ladan freebsd_committer 2020-09-29 17:15:21 UTC
@Andy do you have any updates on this or should we just remove the py-gimp plugin?
Comment 3 Andy Mender 2020-09-29 18:38:27 UTC
(In reply to Rene Ladan from comment #2)

I was hoping to get some feedback from the gnome@FreeBSD.org group, but since no one replied, I think this can be closed.

You can go ahead and remove the plugin. Thanks!
Comment 4 Rene Ladan freebsd_committer 2020-09-29 19:09:15 UTC
(In reply to Andy Mender from comment #3)
OK, I'll remove the plugin. Perhaps it can be re-added once it is upgraded to Python3.

Closing as OBE which seems to be the most suitable option.
Comment 5 commit-hook freebsd_committer 2020-09-29 19:14:25 UTC
A commit references this bug:

Author: rene
Date: Tue Sep 29 19:14:04 UTC 2020
New revision: 550610
URL: https://svnweb.freebsd.org/changeset/ports/550610

Log:
  graphics/gimp: remove optional dependency on expired py-gimp, bump PORTREVISION

  PR:		245519
  Submitted by:	Andy Mender

Changes:
  head/graphics/gimp/Makefile