Bug 246026 - sysutils/automount: Please update to 1.7.2 with attached SHAR file
Summary: sysutils/automount: Please update to 1.7.2 with attached SHAR file
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Many People
Assignee: Jason W. Bacon
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-04-29 13:04 UTC by vermaden
Modified: 2020-04-30 20:54 UTC (History)
1 user (show)

See Also:


Attachments
automount.shar (2.84 KB, text/plain)
2020-04-29 13:04 UTC, vermaden
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description vermaden 2020-04-29 13:04:13 UTC
Created attachment 213911 [details]
automount.shar

Hi.

Please update the 'sysutils/automount' port with attached SHAR file.

Thank You.
Comment 1 Jason W. Bacon freebsd_committer 2020-04-29 13:43:17 UTC
It's hanging during package register for some reason:

make reinstall:

===>  Checking if automount is already installed
===>   Registering installation for automount-1.7.2
Installing automount-1.7.2...
Stopping devd.
Waiting for PIDS: 22788.
Starting devd.


Check /usr/local/bin/automount --help for available options.

ps ax:

23149  0  S+       0:00.01 make reinstall
23163  0  S+       0:00.01 make deinstall install
23193  0  S+       0:00.02 make CONFIG_DONE_AUTOMOUNT=1 /usr/ports/wip/automoun
23486  0  S+       0:00.00 /usr/local/sbin/pkg-static register -i /usr/ports/wi
23487  0  S+       0:00.01 /usr/local/sbin/pkg-static register -i /usr/ports/wi
23489  0  Z+       0:00.03 <defunct>

This is true of the 1.7.1 as well.
Comment 2 Jason W. Bacon freebsd_committer 2020-04-29 20:33:48 UTC
The hang was caused by a faulty pkg-install script.

Furthermore, there is an explicit statement in the handbook that pkg-install should not be used to start services:

https://www.freebsd.org/doc/en_US.ISO8859-1/books/porters-handbook/pkg-install.html

So we should probably use pkg-message instead.
Comment 3 Jason W. Bacon freebsd_committer 2020-04-29 20:59:56 UTC
Also curious why you stopped using Github releases after 1.6.1.

It would be preferable if we could use USE_GITHUB in the port Makefile.
Comment 4 commit-hook freebsd_committer 2020-04-30 19:33:42 UTC
A commit references this bug:

Author: jwb
Date: Thu Apr 30 19:33:25 UTC 2020
New revision: 533470
URL: https://svnweb.freebsd.org/changeset/ports/533470

Log:
  sysutils/automount: Upgrade to 1.7.2

  Fixes mount permissions issues in previous version
  Fixes hang during pkg install
  Removed pkg-install script which violated policy against starting services and
  replaced with a pkg-message instructing user to restart devd

  PR:             ports/246026
  Submitted by:   vermaden@interia.pl

Changes:
  head/sysutils/automount/Makefile
  head/sysutils/automount/distinfo
  head/sysutils/automount/files/
  head/sysutils/automount/pkg-message
Comment 5 Jason W. Bacon freebsd_committer 2020-04-30 19:36:40 UTC
Did not wait for maintainer feedback as there was a critical issue with the previous version (hung indefinitely during package install).  We can still continue the discussion about other issues, of course.
Comment 6 vermaden 2020-04-30 20:54:28 UTC
Thank you for adding the port.



> It's hanging during package register for some reason
> 
> (...)
> 
> This is true of the 1.7.1 as well.

Something must have changed in pkg(8) as 1.7.1 when was introduced to Ports installed properly without any such locks.



> Also curious why you stopped using Github releases after 1.6.1.
> 
> It would be preferable if we could use USE_GITHUB in the port Makefile.

It does not matter for me if I will use USE_GITHUB or just specify where the file is.



Regards.