Bug 246356 - pcap(3) SEE ALSO contains invalid references
Summary: pcap(3) SEE ALSO contains invalid references
Status: Closed Works As Intended
Alias: None
Product: Documentation
Classification: Unclassified
Component: Manual Pages (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-bugs (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-05-10 12:08 UTC by p5B2E9A8F
Modified: 2020-08-08 16:35 UTC (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description p5B2E9A8F 2020-05-10 12:08:46 UTC
SEE ALSO
       autoconf(1), tcpdump(1), tcpslice(1), pcap-filter(@MAN_MISC_INFO@), pfconfig(8),
       usermod(@MAN_ADMIN_COMMANDS@)

but there is nothing for:
$ man 1 autoconf
No manual entry for autoconf
$ man 8 pfconfig
No manual entry for pfconfig
$ apropos usermod
apropos: nothing appropriate
$ man usermod
No manual entry for usermod
Comment 1 p5B2E9A8F 2020-08-08 14:18:59 UTC
Due to lack of feedback I will stop contributing to documentation.
Comment 2 Mateusz Piotrowski freebsd_committer 2020-08-08 16:35:33 UTC
Thank you for your problem report.

Regarding the lack of feedback, it looks like it's a fairly straight forward issue we're facing here: someone would have to write a patch this manual page. At first I'd say there is little to discuss in this case, but actually there is a reason why those references are here: you see, pcap(3) comes from the contrib part of the src tree, which means there is an active upstream. This means 2 things:

1. Patches should ideally be submitted upstream. 
2. A patch for removing those cross references would have to be maintained locally in the FreeBSD tree. This results in more work to be done during future merges of new libpcap versions into the FreeBSD tree. It is actually discouraged (unofficially I guess, but still) to patch little things like this.

This is why I am going to close this PR as Works As Intended.

I'm sorry if the handling of this PR caused frustration on your side. It's always a good idea to ping mailing lists if your PR seems to be rotting on Bugzilla.

Cheers

PS Please keep in mind that most of the documentation committers work on FreeBSD in their spare time and sometimes it takes a bit longer than desired to patch the code base. :)