Bug 246442 - x11-wm/compiz: updates MASTER_SITES
Summary: x11-wm/compiz: updates MASTER_SITES
Status: Closed Overcome By Events
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: freebsd-ports-bugs (Nobody)
URL:
Keywords: buildisok, easy, patch, patch-ready
Depends on:
Blocks:
 
Reported: 2020-05-13 17:51 UTC by Chris Hutchinson
Modified: 2020-06-15 17:51 UTC (History)
2 users (show)

See Also:
freebsd-ports: maintainer-feedback+
freebsd-ports: maintainer-feedback+


Attachments
svn diff for x11-wm/compiz (463 bytes, patch)
2020-05-13 17:51 UTC, Chris Hutchinson
freebsd-ports: maintainer-approval+
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Hutchinson 2020-05-13 17:51:58 UTC
Created attachment 214457 [details]
svn diff for x11-wm/compiz

This port is currently unfetchable. The svn diff
attached to this pr updates MASTER_SITES to correct
that problem.

CHANGES
Makefile: MASTER_SITES

releases.compiz.org is for all practical purposes, is
dead. It still lists a file index. But they can not be
retrieved. It appears that it's been that way since
~2012. As I'm interested in continuing this work. I've
performed a great deal of investigation. Current work
is conducted at
https://code.launchpad.net/compiz, well,
https://launchpad.net/compiz
and while the source tree and history has moved there.
the 0.8.x branch is omitted. There appears to be some
dissension within the ranks. Using this new location
I was able to spin up a copy of Linux, and build and
install a copy of 0.9.12. I chose Linux as the test
bed because the tree already had everything needed in
the debian/ sub folder.
I'm now going to pursue a 0.9x branch for FreeBSD
working from:
https://git.launchpad.net/compiz/commit/?h=0.9.0&id=508ff1dad3d136d1a736d03bbe114faaf251adae
(0.9.0). Unless the current compiz MAINTAINER is already
working on something like this. :-)

That's it!

Thanks!

--Chris
Comment 1 Chris Hutchinson 2020-05-13 17:52:54 UTC
OH, and to prove this patch works as intended:

make -DBATCH fetch
===>  License GPLv2+ LGPL21+ MIT accepted by the user
===>   compiz-0.8.8_9 depends on file: /usr/local/sbin/pkg - found
=> compiz-0.8.8.tar.bz2 doesn't seem to exist in /usr/ports/distfiles/xorg/app.
=> Attempting to fetch https://BSDforge.com/projects/source/x11-wm/compiz/compiz-0.8.8.tar.bz2
compiz-0.8.8.tar.bz2                                  1097 kB   11 MBps    00s
===> Fetching all distfiles required by compiz-0.8.8_9 for building
Comment 2 Steve Wills freebsd_committer 2020-05-13 18:13:49 UTC
Build info is available at https://gitlab.com/swills/freebsd-ports/pipelines/145716345
Comment 3 Daniel Austin 2020-05-13 23:04:30 UTC
All good with me.

Chris, if you want to take over maintainer for any of the compiz ports that I'm listed on please feel free... i really don't have the time to work on them lately :-(


Thanks,

Dan.
Comment 4 Chris Hutchinson 2020-05-14 00:10:00 UTC
(In reply to Daniel Austin from comment #3)
Hello, Dan.

Thanks for the offer! I'd be happy to. most
all the plugins involved are in compiz sub dirs
anyway. So it's not really any additional work. :-)

For the sake of expedience; I'll whip up a mega-diff
changing the MAINTAINER of them to me, for your
approval. I'll reference this pr(1).

Thanks again! :-)

--Chris
Comment 5 commit-hook freebsd_committer 2020-06-14 16:02:15 UTC
A commit references this bug:

Author: zeising
Date: Sun Jun 14 16:01:52 UTC 2020
New revision: 538818
URL: https://svnweb.freebsd.org/changeset/ports/538818

Log:
  Reset maintainer on compiz and related ports

  Reset the maintainer on x11-wm/compiz and a few related ports.
  Update MASTERDIR to make them fetchable again.

  PR:		246461 246442
  Submitted by:	Chris Hutchinson (new maintainer)
  Approved by:	Daniel Austin (previous maintainer)
  MFH:		2020Q2

Changes:
  head/x11-wm/compiz/Makefile
  head/x11-wm/compiz-plugins-main/Makefile
  head/x11-wm/compizconfig-backend-gconf/Makefile
  head/x11-wm/compizconfig-python/Makefile
  head/x11-wm/emerald/Makefile
  head/x11-wm/libcompizconfig/Makefile
Comment 6 Niclas Zeising freebsd_committer 2020-06-14 16:03:35 UTC
This is sort of OBE by the patch in pr246461, closing this.
Comment 7 commit-hook freebsd_committer 2020-06-15 17:51:14 UTC
A commit references this bug:

Author: zeising
Date: Mon Jun 15 17:50:28 UTC 2020
New revision: 538925
URL: https://svnweb.freebsd.org/changeset/ports/538925

Log:
  MFH: r538818

  Reset maintainer on compiz and related ports

  Reset the maintainer on x11-wm/compiz and a few related ports.
  Update MASTERDIR to make them fetchable again.

  PR:		246461 246442
  Submitted by:	Chris Hutchinson (new maintainer)
  Approved by:	Daniel Austin (previous maintainer)

  Approved by:	ports-secteam (joenum)

Changes:
_U  branches/2020Q2/
  branches/2020Q2/x11-wm/compiz/Makefile
  branches/2020Q2/x11-wm/compiz-plugins-main/Makefile
  branches/2020Q2/x11-wm/compizconfig-backend-gconf/Makefile
  branches/2020Q2/x11-wm/compizconfig-python/Makefile
  branches/2020Q2/x11-wm/emerald/Makefile
  branches/2020Q2/x11-wm/libcompizconfig/Makefile