Bug 246466 - sysutils/qjail and logging
Summary: sysutils/qjail and logging
Status: New
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-ports-bugs mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-05-14 12:28 UTC by Igor Konov
Modified: 2020-05-17 12:54 UTC (History)
1 user (show)

See Also:
qjail1: maintainer-feedback+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Igor Konov 2020-05-14 12:28:54 UTC
No log files /var/log/messages and /var/log/maillog inside jail.
Comment 1 Joe Barbish 2020-05-14 16:25:52 UTC
The poster of this bug report is confused on the difference between jail(8) and VM. Using VM would have a /var/log/messages and /var/log/maillog inside the VM from the basic install which is different than how jail(8) works. 

Qjail is just a wrapper for the jail(8) command and as such has the same limits as jail(8). What the poster expects to find in the messages file (boot post messages) do not happen in jail(8). What little information coming from the statements in the jails rc.conf file go to the host /var/log/qjail.jailname.console.log file for easy access by the host jail administrator. This log file can be considered as the messages file but with a different name and very limited content. 

The /var/log/maillog is used by sendmail which is not started by default in qjail jails because the cron daily, weekly, monthly reports are not run in the jail(8) jail. 

What the poster thinks is a qjail bug is really just the posters lack of understanding of how jail(8) works. The maintainer of qjail says this bug report is invalid and is NOT a bug and can be closed.
Comment 2 Igor Konov 2020-05-14 19:47:30 UTC
I think this answer is not constructive.
I have been using jail for a long time. But when using qjail, I encountered a lack of log files. I am running sendmail inside jail, but maillog is missing.
Comment 3 Igor Konov 2020-05-17 12:54:24 UTC
I solved the problem by creating a log file myself.
 # cd /var/log
 # touch maillog
 # chmod o-r maillog
And restart jail.