Bug 246640 - lang/cmucl does not work under 12.1
Summary: lang/cmucl does not work under 12.1
Status: New
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Many People
Assignee: freebsd-ports-bugs (Nobody)
Depends on:
Reported: 2020-05-21 17:34 UTC by Bertrand Petit
Modified: 2021-04-05 10:44 UTC (History)
3 users (show)

See Also:


Note You need to log in before you can comment on or make changes to this bug.
Description Bertrand Petit 2020-05-21 17:34:27 UTC
After installing cmucl-21.b, while trying to configure maxima, lisp(1) did complain that his living location does not please it.

$ lisp

   Cannot find #P"ext-formats:unidata.bin", so unicode support is not available
   [Condition of type SIMPLE-ERROR]

  0: [CONTINUE] Continue anyway
  1: [ABORT   ] Skip remaining initializations.

Debug  (type H for help)

Source: Error finding source: 
Error in function DEBUG::GET-FILE-TOP-LEVEL-FORM:  Source file no longer exists:

Since the steel bank compiler does not build either under 12.1, I'm prevented to install maxima.
Comment 1 Lorenzo Salvadore freebsd_committer 2020-05-21 20:10:52 UTC
Hello, I am the maxima maintainer.

Unfortunately, I think fixing cmucl will require someone with a high knowledge of lisp and of the software itself.
However sbcl should work. Some users reported issues with the THREAD option (I have issues as well): try rebuilding sbcl switching its state and see if it gets any better.
Comment 2 Jason Robinson 2020-05-28 23:33:46 UTC
I have the exact issue on my FreeBSD build 12.1-RELEASE-p3 GENERIC amd64.

Additionally it occurs whenever trying to load any file, either during initialization or using LOAD. TRUENAME will also throw the same error. Setting the LDCONFIG path or using the wrapper that came with it does not change anything.

I had planned (and still want to) on using CMUCL for local development as well as for production.
Comment 3 Bertrand Petit 2020-05-30 07:02:54 UTC
(In reply to Lorenzo Salvadore from comment #1)
I tried to install CMUCL because I previously couldn't install SBCL, I had a build failure. I then did another SBCL build attempt and, this time, it completed without error. I can't explain that transient error.

I can run maxima. Thank you.
Comment 4 Bertrand Petit 2020-05-30 07:07:15 UTC
(In reply to Jason Robinson from comment #2)
Since CMUCL is a binary port, I suppose a change in the toolchain upsets it. Could SBCL be used as a bootstrap to build CMUCL from sources?
Comment 5 Jason Robinson 2021-04-04 22:01:24 UTC
(In reply to Bertrand Petit from comment #4)
Thanks for the response. Unfortunately, due to work, I was pulled off this and ended up using Clozure. However for personal reasons I am still interested in getting this working. 

I have never bootstrapped Common Lisp before, would the instructions found here ( https://gitlab.common-lisp.net/cmucl/cmucl/-/wikis/BuildingCmucl ) work? If not, can you point me in the right direction?
Comment 6 Bertrand Petit 2021-04-05 10:44:07 UTC
(In reply to Jason Robinson from comment #5)
Lorenzo is certainly right in writing that this "will require someone with a high knowledge of lisp and of the software itself." CMUCL works 21b 11.2-RELEASE but no longer on 12-something. Upstream has not provided a binary for FreeBSD since 2017. So, today building a new distribution would require crossing releases version barriers (from an 11-based host?), that may not be simple but would certainly be extremely instructive.