Bug 246741 - audio/openal-soft: Enable sndio by default
Summary: audio/openal-soft: Enable sndio by default
Status: Closed Works As Intended
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Tobias Kortkamp
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-05-26 08:39 UTC by Evilham
Modified: 2020-07-17 21:09 UTC (History)
0 users

See Also:
bugzilla: maintainer-feedback? (tobik)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Evilham 2020-05-26 08:39:14 UTC
Follow up from #246726 (sndio in multimedia/mpv) and #211664 (added the sndio option to audio/openal-soft).

It looks like enabling sndio by default on openal-soft might be tricky, because the package starts depending on sndio and that means that for all packages that depend on openal-soft (that's over 100 ports), sndio would be a transitive dependency.

Maybe this could be considered similar to how wayland was enabled by default? I don't really know how that came to happen, but it certainly is making things easier for wayland adoption.
Comment 1 Tobias Kortkamp freebsd_committer 2020-05-26 15:17:51 UTC
> sndio would be a transitive dependency.

*shrug* audio/sndio does not have any dependencies itself and is fairly small
so this is justifiable IMHO.

The only downside in enabling it by default is that OpenAL will prefer
the "sndio" driver over "oss", but I doubt many people would notice at all.