Bug 246907 - devel/cpputest: Update to 4.0
Summary: devel/cpputest: Update to 4.0
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Fernando Apesteguía
URL: https://github.com/cpputest/cpputest/...
Keywords: buildisok
Depends on:
Blocks:
 
Reported: 2020-06-01 10:51 UTC by Akos Somfai
Modified: 2020-06-02 05:52 UTC (History)
2 users (show)

See Also:


Attachments
patch for upgrade (2.12 KB, patch)
2020-06-01 10:51 UTC, Akos Somfai
akos.somfai: maintainer-approval+
Details | Diff
poudriere logs (68.19 KB, text/plain)
2020-06-01 10:52 UTC, Akos Somfai
no flags Details
additional improvements on top of submitter's patch (2.28 KB, patch)
2020-06-01 13:12 UTC, Fernando Apesteguía
akos.somfai: maintainer-approval+
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Akos Somfai 2020-06-01 10:51:31 UTC
Created attachment 215127 [details]
patch for upgrade

Hi, this is an update for devel/cpputest to 4.0. Attaching port patch and poudriere logs
Comment 1 Akos Somfai 2020-06-01 10:52:00 UTC
Created attachment 215128 [details]
poudriere logs
Comment 2 Automation User 2020-06-01 11:10:49 UTC
Build info is available at https://gitlab.com/swills/freebsd-ports/pipelines/151548827
Comment 3 Fernando Apesteguía freebsd_committer 2020-06-01 12:23:27 UTC
^Triage: Please set the maintainer-approval attachment flag (to +) on patches for ports you maintain to signify approval

Attachment -> Details -> maintainer-approval [+]

Also, setting maintainer-approval is enough, we can get rid of the [MAINTAINER] tag :-)

Thanks!
Comment 4 Akos Somfai 2020-06-01 13:08:07 UTC
(In reply to Fernando Apesteguía from comment #3)
Ok, flag set.
Akos
Comment 5 Fernando Apesteguía freebsd_committer 2020-06-01 13:12:06 UTC
Created attachment 215131 [details]
additional improvements on top of submitter's patch

One last thing, I reordered USE_/USES:

$ portlint -AC                                                                                         
WARN: Makefile: [13]: USE_* seen before USES.  According to the porters-handbook, USES must appear first.
WARN: Makefile: for new port, make $FreeBSD$ tag in comment section empty, to make SVN happy.
WARN: Makefile: "USES" has to appear earlier.                                   
0 fatal errors and 3 warnings found.
Comment 6 commit-hook freebsd_committer 2020-06-02 05:52:22 UTC
A commit references this bug:

Author: fernape
Date: Tue Jun  2 05:51:58 UTC 2020
New revision: 537521
URL: https://svnweb.freebsd.org/changeset/ports/537521

Log:
  devel/cpputest: Update to 4.0

  From ChangeLog: https://github.com/cpputest/cpputest/releases/tag/v4.0

  New functionality:

   * Added MemoryAccountant
   * Added SimpleStringCache that also removed the memory leak caused by longjmp
     in C
   * Thread-safe memory leak detector overloads
   * New command-line options:
   *     -h help option
   *     -s shuffle (random) option
   *     -t run a specific test option
   *     -vv extra verbose option
   *     -k add a package name to junit output
   * Added new asserts: CHECK_COMPARE, and improved C macros
   * Support for newer compilers and address sanitizer

  Small improvements:

   * Fixed problems with gdb
   * More 16-bit support
   * Added Makefile for making the examples with an installed CppUTest
   * Small mock improvements
   * Removed more compiler warnings
   * Support for C++14, C++17, and C++2x (added to automated build)

  Improved maintainability:

   * Docker builds
   * Vastly improved the automated build with more platforms and variants
   * Continuously releasing the passing build
   * MS-DOS support (added to automated build)

  PR:	246907
  Submitted by:	akos.somfai@gmail.com (maintainer)

Changes:
  head/devel/cpputest/Makefile
  head/devel/cpputest/distinfo
  head/devel/cpputest/pkg-plist
Comment 7 Fernando Apesteguía freebsd_committer 2020-06-02 05:52:45 UTC
Committed,

Thanks!