Bug 247131 - vm: Fix typos
Summary: vm: Fix typos
Status: Open
Alias: None
Product: Base System
Classification: Unclassified
Component: kern (show other bugs)
Version: CURRENT
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-bugs (Nobody)
Keywords: easy, needs-qa
Depends on:
Reported: 2020-06-10 00:40 UTC by Sebastien Boisvert
Modified: 2020-07-10 18:35 UTC (History)
2 users (show)

See Also:
koobs: maintainer-feedback? (markj)
mjg: maintainer-feedback-

Fix some typos in sys/vm/ (13.79 KB, patch)
2020-06-10 00:50 UTC, Sebastien Boisvert
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Sebastien Boisvert 2020-06-10 00:40:11 UTC

Comment 1 Sebastien Boisvert 2020-06-10 00:50:37 UTC
Created attachment 215413 [details]
Fix some typos in sys/vm/
Comment 2 Mark Johnston freebsd_committer 2020-06-10 16:04:21 UTC
I'm not a big fan of this patch: the typos don't really hurt readability, and fixing them will pollute the commit history, making it harder to find the original commit that added a given line.

The changes are also not really consistent.  For example:
- One change to swap_pager.c changes "SWAP" to "OBJT_SWAP", but leaves "DEFAULT" as-is.
- One hunk changes one instance "type-stability" to "type stability" (why?), but that term appears in multiple places in sys/vm.
- A couple of changes add a period to the end of a sentence, but leave the sentence uncapitalized.

If we are going to churn the sources, the diff should fix as many problems as possible while not introducing inconsistencies.  In general I'd prefer to see patches that rewrite comments to make them more useful, fixing typos as a side effect, or simply deleting self-evident comments like /* remove kernel mappings */ followed by a pmap_qremove() call.
Comment 3 Sebastien Boisvert 2020-06-11 00:12:44 UTC
Hello Mark Johnston,

Thank you for your feedback.

Do you want me to do a much smaller v2 with only those real typos ?

- on-the-fly (since in the same file it is written already on-the-fly elsewhere_
- backward-looking (no s)
- enqueing -> enqueuing
- xbusied -> busied (maybe xbusied means something, I don't know)
- remove the mapping for kernel virtual memory (the word memory is missing)
- If an error occurs while writing to swap  (missing 'while')
- any pending paging
- valid block and ensure that all pending paging operations (any vs all)
- least vs lowest
- sqeeze -> squeeze
- lets -> let's
Comment 4 Mark Johnston freebsd_committer 2020-07-10 18:35:40 UTC
(In reply to Sebastien Boisvert from comment #3)
I'm sorry, I missed this reply somehow.  I have no problem working with a patch that just fixes grammar and typos.  "xbusied" is correct and should not be changed.  It would be easier to discuss such a patch on phabricator, since there will probably be some follow-up suggestions if we're going to take the time to try and fix up miscellaneous comments: https://wiki.freebsd.org/Phabricator