Bug 247444 - editors/libreoffice: Erroneous print output in 6.4.4
Summary: editors/libreoffice: Erroneous print output in 6.4.4
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-office (Nobody)
URL:
Keywords: needs-qa
: 247479 (view as bug list)
Depends on:
Blocks:
 
Reported: 2020-06-20 18:30 UTC by peo
Modified: 2020-07-11 08:16 UTC (History)
11 users (show)

See Also:
bugzilla: maintainer-feedback? (office)


Attachments
printout example (4.02 KB, application/pdf)
2020-06-20 18:30 UTC, peo
no flags Details
export to pdf (822.38 KB, image/png)
2020-06-22 13:30 UTC, Dima Panov
no flags Details
patch (1.35 KB, patch)
2020-06-29 19:25 UTC, Tijl Coosemans
no flags Details | Diff
patch2 (2.40 KB, patch)
2020-07-05 19:49 UTC, Tijl Coosemans
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description peo 2020-06-20 18:30:26 UTC
Created attachment 215824 [details]
printout example

12.1-STABLE r362185 GENERIC  amd64
libreoffice-6.4.4_2 built from ports, all ports updated May 19
cups-2.2.13
cups-filters-1.27.5
cups-pdf-3.0.1

LANGUAGE=
LC_CTYPE=sv_SE.UTF-8

OPTIONS_FILE_SET+=CUPS
OPTIONS_FILE_UNSET+=DOCS
OPTIONS_FILE_UNSET+=GNOME
OPTIONS_FILE_UNSET+=GTK3
OPTIONS_FILE_SET+=JAVA
OPTIONS_FILE_SET+=KF5
OPTIONS_FILE_SET+=MMEDIA
OPTIONS_FILE_UNSET+=PGSQL
OPTIONS_FILE_SET+=QT5
OPTIONS_FILE_UNSET+=SDK
OPTIONS_FILE_SET+=TEST
OPTIONS_FILE_SET+=WEBDAV

Since update from 6.3.4_5, output is just a few characters in random places over the printed page.

Regardless of printer type
Export to pdf produces a blank page
Printing from other apps is fine

Did,
portmaster -d -f -t /usr/ports/editors/libreoffice
ie. rebuilt all dependencies from sctratch just to make sure there was not any problems there.
Comment 1 Rainer Hurling 2020-06-21 19:53:42 UTC
Same problem on 13.0-CURRENT amd64 r362466.

LANG=de_DE.UTF-8
LC_CTYPE=de_DE.UTF-8
LC_TIME=de_DE.UTF-8
LC_COLLATE=C
LC_NUMERIC=de_DE.UTF-8
LC_MONETARY=de_DE.UTF-8


Ports options are:

CUPS=on: CUPS printing system support
DOCS=on: Build and/or install documentation
GNOME=off: GNOME desktop environment support
GTK3=off: GTK+ 3 GUI toolkit support (broken visual style)
JAVA=on: Add Java support (XML filters, macros, DB connections)
KF5=on: KF5/Qt5 GUI toolkit support (implies QT5)
MMEDIA=off: Enable multimedia backend for Impress
PGSQL=off: Build with PostgreSQL-SDBC driver
QT5=on: Qt5 GUI toolkit support (default visual style)
SDK=off: Build with SDK
TEST=off: Run all regression tests
WEBDAV=off: Enable WebDAV protocol
Comment 2 Dima Panov freebsd_committer 2020-06-22 13:30:35 UTC
Created attachment 215858 [details]
export to pdf

Folks, cannot reproduce with poudriere-built packages:(

LANG=ru_RU.UTF-8

Export to pdf produce a valid file
Print to pdf is also fine.

cups-2.2.13                    Common UNIX Printing System
cups-filters-1.27.4_1          Additional backends, filters and other software for CUPS
cups-pdf-3.0.1                 Virtual printer for CUPS to produce PDF files

Name           : libreoffice
Version        : 6.4.4
Installed on   : Mon Jun 22 05:28:01 2020 +10
Architecture   : FreeBSD:12:amd64
Options        :
	CUPS           : on
	DOCS           : off
	GNOME          : off
	GTK3           : off
	JAVA           : on
	KF5            : on
	MMEDIA         : on
	PGSQL          : off
	QT5            : on
	SDK            : off
	TEST           : off
	WEBDAV         : on
Comment 3 Lewis Cook freebsd_triage 2020-06-22 17:59:28 UTC
*** Bug 247479 has been marked as a duplicate of this bug. ***
Comment 4 bergerkos 2020-06-22 18:13:39 UTC
I DO have the same issue -- both with locally built 6.4.4 and with official package 6.4.4.2. 
My local packages are ALL from my local repository built with Synth. Very unlikely that it missed any dependencies.

The official pre-built packages, for the purity of experiment, are all installed into a separate clean installation, for a newly created user, using `pkg install` from repo. Missing dependencies are also unlikely, as well as possible "foreign" user settings.

I must add that PS printing works all right. So, going to Tools > Options > Print and unchecking the box for 'using PDF as default job format' creates valid PS output.
Comment 5 bergerkos 2020-06-22 18:15:13 UTC
(In reply to Dima Panov from comment #2)
Do you mean creating your PDF files using CUPS-PDF?
I'm talking about creating PDF files using PDF icon in libreoffice interface.
Comment 6 bergerkos 2020-06-22 18:20:29 UTC
Oh, and this problem seems to only concern the text. While exporting to PDF graphics and tables are exported all right. Only text is missing.
Comment 7 Dima Panov freebsd_committer 2020-06-22 18:41:42 UTC
(In reply to bergerkos from comment #5)
nope, I meant "export as pdf" -- button and via menu
same for print -- print to file - as pdf

as u can see on screenshot -- text is not garbled, all cyrillic and latin chars on place

I have an idea. Try to set a global MM_CHARSET=UTF-8 for profile. 

my ~/.login_conf:

me:\
        :charset=UTF-8:\
        :lang=en_GB.UTF-8:\
        :tc=default:
Comment 8 bergerkos 2020-06-23 08:36:57 UTC
(In reply to Dima Panov from comment #7)
Unfortunately, this doesn't change anything.

Now I wonder which poppler version you are using. Maybe it's different from mine? And it's poppler that's responsible for PDF rendering, isn't it.
Comment 9 rob2g2 2020-06-23 16:40:36 UTC
same problem here on 12.1, installed via pkg (latest). Export to PDF or print to file produces a small file without any text, tables are present.
Comment 10 Jason W. Bacon freebsd_committer 2020-06-27 00:35:42 UTC
My attempts to print to laserjet, print to PDF, or export to PDF all produce blank pages.  Exporting to PNG works fine.

Running libreoffice from a terminal doesn't produce much output, but here it is:

FreeBSD coral.acadix  bacon ~ 1003: libreoffice
MESA-LOADER: failed to retrieve device information
QKqueueFileSystemWatcherEngine::addPaths: open: No such file or directory

Everything installed via latest packages

FreeBSD coral.acadix.biz 12.1-RELEASE-p6 FreeBSD 12.1-RELEASE-p6 GENERIC  amd64
Comment 11 tech-lists 2020-06-27 19:18:57 UTC
I have the same issue, using 12-stable r360999 latest ports tree, built on poudriere. same problem exists on a fresh 12.1-R-p6 with quarterly packages.

Make a txt file, allow it to be saved in the default odt format, click the PDF button to export to PDF, a file is created but with no text. If you do the same with a textfile a couple of pages long, the empty PDF will also be a couple of pages long.

The system views PDF files not created with libreoffice just fine. On another machine (linux mint 18.04) this has libreoffice5 and it exports to PDF fine.

I think it's a libreoffice6 problem as libreoffice has always been able to export to PDF (and epub) natively.

It's been reported affecting ubuntu 20.04 and derivatives as well:

https://ask.libreoffice.org/en/question/242188/cannot-print-anything-exporting-to-pdf-produces-blank-pdf-lubuntu-2004/

https://ask.libreoffice.org/en/question/241673/export-or-print-to-pdf-no-text/

the fix there seems to be to purge then reinstall, that infers ubuntu have updated their libreoffice package. How new is the libreoffice6 in ports?
Comment 12 tech-lists 2020-06-28 09:14:36 UTC
seems the problem started ahppening after the upgrade 6.3.6_1 -> 6.4.4
Comment 13 Tijl Coosemans freebsd_committer 2020-06-28 13:13:26 UTC
What desktop are you using and what VCL is libreoffice using (Help->About Libreoffice)?
Comment 14 peo 2020-06-28 14:21:43 UTC
xfce4-wm-4.14.2
+ a lot of Qt5/KDE stuff

Version: 6.4.4.2
Build ID: FreeBSD ports r6.4.4
CPU threads: 12; OS: FreeBSD 12.1; UI render: default; VCL: qt5; 
Locale: sv-SE (sv_SE.UTF-8); UI-Language: en-US
Calc: threaded
Comment 15 Tijl Coosemans freebsd_committer 2020-06-28 15:02:01 UTC
What is the output of "env | grep DESKTOP" and "env | grep SAL"?

Try one of the following:

env SAL_USE_VCLPLUGIN=gen libreoffice
env SAL_USE_VCLPLUGIN=kf5 libreoffice
Comment 16 peo 2020-06-28 15:13:53 UTC
DESKTOP_SESSION=xfce
XDG_CURRENT_DESKTOP=XFCE

env SAL_USE_VCLPLUGIN=gen libreoffice
env SAL_USE_VCLPLUGIN=kf5 libreoffice

Both produces a correct pdf
Comment 17 tech-lists 2020-06-28 15:19:20 UTC
(In reply to Tijl Coosemans from comment #13)
Hi,

I'm using windowmaker-0.95.8_2 and the VCL is qt5 (qt5-core is 5.14.2_3)
Comment 18 peo 2020-06-28 15:26:28 UTC
env | grep SAL
produces nothing.

Now tested
env SAL_USE_VCLPLUGIN=gen libreoffice
env SAL_USE_VCLPLUGIN=kf5 libreoffice
and both works with all available printers I happen to have access to right now.
Comment 19 Tijl Coosemans freebsd_committer 2020-06-28 15:35:56 UTC
Does this work:

env SAL_VCL_QT5_USE_CAIRO=yes libreoffice
Comment 20 tech-lists 2020-06-28 15:37:29 UTC
(In reply to Tijl Coosemans from comment #15)

> What is the output of "env | grep DESKTOP" and "env | grep SAL"?

Nothing

> Try one of the following:

> env SAL_USE_VCLPLUGIN=gen libreoffice
> env SAL_USE_VCLPLUGIN=kf5 libreoffice

These both work.

I tried using this:

env SAL_USE_VCLPLUGIN=qt5 libreoffice

and we're back to blank PDFs
Comment 21 tech-lists 2020-06-28 15:39:22 UTC
(In reply to Tijl Coosemans from comment #19)

> Does this work:

> env SAL_VCL_QT5_USE_CAIRO=yes libreoffice

no this produces garbled output when libreoffice starts
Comment 22 Rainer Hurling 2020-06-28 15:53:49 UTC
(In reply to Tijl Coosemans from comment #19)

env SAL_VCL_QT5_USE_CAIRO=yes libreoffice

works fine for me with WindowMaker and settings, described in comment #1. Many thanks!
Comment 23 peo 2020-06-28 15:54:48 UTC
env SAL_VCL_QT5_USE_CAIRO=yes libreoffice

garbled here too
Comment 24 bergerkos 2020-06-28 19:35:48 UTC
(In reply to Tijl Coosemans from comment #15)
There is no SAL| DESKTOP in my env.

env SAL_USE_VCLPLUGIN=gen libreoffice works fine and produces PDF as it should.
env SAL_USE_VCLPLUGIN=kf5 libreoffice doesn't, but then again my libreoffice was build with kf5=off.

Thank you!
Comment 25 bergerkos 2020-06-28 19:36:14 UTC
(In reply to tech-lists from comment #21)
Same here.
Comment 26 Jason W. Bacon freebsd_committer 2020-06-29 18:48:00 UTC
Don't know if this is helpful, but running qpdf on a LibreOffice PDF export from a terminal:

FreeBSD coral.acadix  bacon ~ 1005: qpdfview residence.pdf 
MESA-LOADER: failed to retrieve device information
QKqueueFileSystemWatcherEngine::addPaths: open: No such file or directory
"Error: Unknown font tag 'F1'"
"Error (334): No font in show/space"
"Error: Unknown font tag 'F1'"
"Error (379): No font in show/space"
"Error: Unknown font tag 'F1'"
"Error (427): No font in show/space"
"Error: Unknown font tag 'F1'"
"Error (476): No font in show/space"
"Error: Unknown font tag 'F1'"
"Error (534): No font in show/space"
"Error: Unknown font tag 'F1'"
"Error (583): No font in show/space"
"Error: Unknown font tag 'F1'"
"Error (613): No font in show/space"
"Error: Unknown font tag 'F1'"
"Error (624): No font in show"
"Error: Unknown font tag 'F1'"
"Error (647): No font in show/space"
"Error: Unknown font tag 'F1'"
"Error (695): No font in show/space"
"Error: Unknown font tag 'F1'"
"Error (834): No font in show/space"
"Error: Unknown font tag 'F1'"
"Error (989): No font in show/space"
"Error: Unknown font tag 'F1'"
"Error (1054): No font in show/space"
"Error: Unknown font tag 'F1'"
"Error (1150): No font in show/space"
"Error: Unknown font tag 'F1'"
"Error (1178): No font in show/space"
"Error: Unknown font tag 'F1'"
"Error (1205): No font in show/space"
"Error: Unknown font tag 'F1'"
"Error (1217): No font in show/space"
"Error: Unknown font tag 'F1'"
"Error (334): No font in show/space"
"Error: Unknown font tag 'F1'"
"Error (379): No font in show/space"
"Error: Unknown font tag 'F1'"
"Error (427): No font in show/space"
"Error: Unknown font tag 'F1'"
"Error (476): No font in show/space"
"Error: Unknown font tag 'F1'"
"Error (534): No font in show/space"
"Error: Unknown font tag 'F1'"
"Error (583): No font in show/space"
"Error: Unknown font tag 'F1'"
"Error (613): No font in show/space"
"Error: Unknown font tag 'F1'"
"Error (624): No font in show"
"Error: Unknown font tag 'F1'"
"Error (647): No font in show/space"
"Error: Unknown font tag 'F1'"
"Error (695): No font in show/space"
"Error: Unknown font tag 'F1'"
"Error (834): No font in show/space"
"Error: Unknown font tag 'F1'"
"Error (989): No font in show/space"
"Error: Unknown font tag 'F1'"
"Error (1054): No font in show/space"
"Error: Unknown font tag 'F1'"
"Error (1150): No font in show/space"
"Error: Unknown font tag 'F1'"
"Error (1178): No font in show/space"
"Error: Unknown font tag 'F1'"
"Error (1205): No font in show/space"
"Error: Unknown font tag 'F1'"
"Error (1217): No font in show/space"
"Error: Unknown font tag 'F1'"
"Error (1524): No font in show/space"
"Error: Unknown font tag 'F1'"
"Error (1720): No font in show/space"
"Error: Unknown font tag 'F1'"
"Error (1773): No font in show/space"
"Error: Unknown font tag 'F1'"
"Error (1809): No font in show/space"
"Error: Unknown font tag 'F1'"
"Error (1848): No font in show/space"
"Error: Unknown font tag 'F1'"
"Error (1940): No font in show/space"
"Error: Unknown font tag 'F1'"
"Error (2078): No font in show/space"
"Error: Unknown font tag 'F1'"
"Error (2092): No font in show/space"
"Error: Unknown font tag 'F1'"
"Error (2191): No font in show/space"
"Error: Unknown font tag 'F1'"
"Error (2224): No font in show/space"
"Error: Unknown font tag 'F1'"
"Error (2259): No font in show/space"
"Error: Unknown font tag 'F1'"
"Error (2282): No font in show/space"
"Error: Unknown font tag 'F1'"
"Error (2298): No font in show"
Comment 27 Tijl Coosemans freebsd_committer 2020-06-29 19:25:56 UTC
Created attachment 216046 [details]
patch

I cannot reproduce the garbled output, but those who can please try the attached patch.  The kf5 back end uses the qt5 back end with cairo and only a few changes on top of that, so if kf5 works, qt5+cairo should work too.  This patch takes one of the changes in the kf5 back end and applies it to the qt5 back end.

You can apply this patch to the ports tree using:

cd /usr/ports
svn patch /path/to/patchfile

Then rebuild and reinstall libreoffice and run it using:

env SAL_VCL_QT5_USE_CAIRO=yes libreoffice
Comment 28 peo 2020-06-29 22:10:08 UTC
Comment on attachment 216046 [details]
patch

Just rebuilt, ports at 540693 + applied patch.

Still garbled.

env SAL_USE_VCLPLUGIN=kf5 libreoffice

workds as before with ok prints and pdfs
Comment 29 tech-lists 2020-06-30 14:43:56 UTC
(In reply to Tijl Coosemans from comment #27)
OK, it's rebuilding now with the patch applied.
Comment 30 tech-lists 2020-06-30 15:53:54 UTC
(In reply to Tijl Coosemans from comment #27)

Ok, that worked (with patch).

When Libreoffice starts, it occupies about 90% of the screen, and there's garbled output occupying about 10% of the libreoffice window. Re-sizing the screen normalises the window. Direct conversion to PDF works (using the icon at the top of the writer window).

Here is output of help:

Version: 6.4.4.2
Build ID: FreeBSD ports r6.4.4
CPU threads: 8; OS: FreeBSD 12.1; UI render: default; VCL: qt5+cairo; 
Locale: en-GB (en_GB.UTF-8); UI-Language: en-GB
Calc: threaded
Comment 31 Dima Panov freebsd_committer 2020-06-30 15:57:05 UTC
(In reply to Tijl Coosemans from comment #27)

qt5+cairo works even without patch, but have startup visual glitch (move or resize window to get a fine redraw)
qt5 pure still produce a bad pdf
Comment 32 tech-lists 2020-06-30 15:58:15 UTC
additionally, even with the patched libreoffice, this:

env SAL_USE_VCLPLUGIN=qt5 libreoffice

still gives blank PDFs
Comment 33 bergerkos 2020-07-04 19:53:38 UTC
Ok, for me 
env SAL_VCL_QT5_USE_CAIRO=yes libreoffice

works fine. Print to PDF as expected. Garbled window -- yes, a little bit. But not every time even. And, as was commented, disappears with as soon as you resize.

Didn't try the patch yet, Synth rebuilds 130 packages for that, I just didn't have that time yet...
Comment 34 bergerkos 2020-07-04 19:56:09 UTC
(In reply to bergerkos from comment #33)
It pulls in additional dependencies as I change to KF5=yes. This far it only has QT5, apart from CUPS and other non-related options.
Comment 35 Tijl Coosemans freebsd_committer 2020-07-05 19:49:37 UTC
Created attachment 216233 [details]
patch2

I managed to reproduce the garbled UI and here's a patch that fixed it for me.  If you applied the previous patch you can revert it using "rm /usr/ports/editors/libreoffice/files/patch-vcl_qt5_Qt5Instance.cxx".  Then apply this new patch as before:

cd /usr/ports
svn patch /path/to/patchfile

Then rebuild and reinstall libreoffice and run it using:

env SAL_VCL_QT5_USE_CAIRO=yes libreoffice
Comment 36 commit-hook freebsd_committer 2020-07-07 03:15:52 UTC
A commit references this bug:

Author: fluffy
Date: Tue Jul  7 03:15:19 UTC 2020
New revision: 541383
URL: https://svnweb.freebsd.org/changeset/ports/541383

Log:
  Update LibreOffice suite to 6.4.5 release

  QT5 VCL fixes:
  - Reduce startup flickering
  - Always use cairo font renderer

  Special thanks to:	tijl

  PR:		247444

Changes:
  head/arabic/libreoffice/distinfo
  head/chinese/libreoffice-zh_CN/distinfo
  head/chinese/libreoffice-zh_TW/distinfo
  head/editors/libreoffice/Makefile
  head/editors/libreoffice/Makefile.common
  head/editors/libreoffice/distinfo
  head/editors/libreoffice/files/patch-sc_source_core_opencl_formulagroupcl.cxx
  head/editors/libreoffice/files/patch-sdext_source_pdfimport_xpdfwrapper_pdfioutdev__gpl.cxx
  head/editors/libreoffice/files/patch-vcl_qt5_Qt5Frame.cxx
  head/editors/libreoffice/files/patch-vcl_qt5_Qt5Instance.cxx
  head/editors/libreoffice-af/distinfo
  head/editors/libreoffice-am/distinfo
  head/editors/libreoffice-as/distinfo
  head/editors/libreoffice-ast/distinfo
  head/editors/libreoffice-be/distinfo
  head/editors/libreoffice-bg/distinfo
  head/editors/libreoffice-bn/distinfo
  head/editors/libreoffice-bn_IN/distinfo
  head/editors/libreoffice-bo/distinfo
  head/editors/libreoffice-br/distinfo
  head/editors/libreoffice-brx/distinfo
  head/editors/libreoffice-bs/distinfo
  head/editors/libreoffice-ca/distinfo
  head/editors/libreoffice-ca_valencia/distinfo
  head/editors/libreoffice-cs/distinfo
  head/editors/libreoffice-cy/distinfo
  head/editors/libreoffice-da/distinfo
  head/editors/libreoffice-dgo/distinfo
  head/editors/libreoffice-dsb/distinfo
  head/editors/libreoffice-dz/distinfo
  head/editors/libreoffice-el/distinfo
  head/editors/libreoffice-en_GB/distinfo
  head/editors/libreoffice-en_ZA/distinfo
  head/editors/libreoffice-eo/distinfo
  head/editors/libreoffice-es/distinfo
  head/editors/libreoffice-et/distinfo
  head/editors/libreoffice-eu/distinfo
  head/editors/libreoffice-fa/distinfo
  head/editors/libreoffice-fi/distinfo
  head/editors/libreoffice-fy/distinfo
  head/editors/libreoffice-ga/distinfo
  head/editors/libreoffice-gd/distinfo
  head/editors/libreoffice-gl/distinfo
  head/editors/libreoffice-gu/distinfo
  head/editors/libreoffice-gug/distinfo
  head/editors/libreoffice-hi/distinfo
  head/editors/libreoffice-hr/distinfo
  head/editors/libreoffice-hsb/distinfo
  head/editors/libreoffice-id/distinfo
  head/editors/libreoffice-is/distinfo
  head/editors/libreoffice-it/distinfo
  head/editors/libreoffice-ka/distinfo
  head/editors/libreoffice-kab/distinfo
  head/editors/libreoffice-kk/distinfo
  head/editors/libreoffice-km/distinfo
  head/editors/libreoffice-kmr_Latn/distinfo
  head/editors/libreoffice-kn/distinfo
  head/editors/libreoffice-kok/distinfo
  head/editors/libreoffice-ks/distinfo
  head/editors/libreoffice-lb/distinfo
  head/editors/libreoffice-lo/distinfo
  head/editors/libreoffice-lt/distinfo
  head/editors/libreoffice-lv/distinfo
  head/editors/libreoffice-mai/distinfo
  head/editors/libreoffice-mk/distinfo
  head/editors/libreoffice-ml/distinfo
  head/editors/libreoffice-mn/distinfo
  head/editors/libreoffice-mni/distinfo
  head/editors/libreoffice-mr/distinfo
  head/editors/libreoffice-my/distinfo
  head/editors/libreoffice-nb/distinfo
  head/editors/libreoffice-ne/distinfo
  head/editors/libreoffice-nl/distinfo
  head/editors/libreoffice-nn/distinfo
  head/editors/libreoffice-nr/distinfo
  head/editors/libreoffice-nso/distinfo
  head/editors/libreoffice-oc/distinfo
  head/editors/libreoffice-om/distinfo
  head/editors/libreoffice-or/distinfo
  head/editors/libreoffice-pa_IN/distinfo
  head/editors/libreoffice-ro/distinfo
  head/editors/libreoffice-rw/distinfo
  head/editors/libreoffice-sa_IN/distinfo
  head/editors/libreoffice-sat/distinfo
  head/editors/libreoffice-sd/distinfo
  head/editors/libreoffice-si/distinfo
  head/editors/libreoffice-sid/distinfo
  head/editors/libreoffice-sk/distinfo
  head/editors/libreoffice-sl/distinfo
  head/editors/libreoffice-sq/distinfo
  head/editors/libreoffice-sr/distinfo
  head/editors/libreoffice-sr_Latn/distinfo
  head/editors/libreoffice-ss/distinfo
  head/editors/libreoffice-st/distinfo
  head/editors/libreoffice-sv/distinfo
  head/editors/libreoffice-sw_TZ/distinfo
  head/editors/libreoffice-szl/distinfo
  head/editors/libreoffice-ta/distinfo
  head/editors/libreoffice-te/distinfo
  head/editors/libreoffice-tg/distinfo
  head/editors/libreoffice-th/distinfo
  head/editors/libreoffice-tn/distinfo
  head/editors/libreoffice-tr/distinfo
  head/editors/libreoffice-ts/distinfo
  head/editors/libreoffice-tt/distinfo
  head/editors/libreoffice-ug/distinfo
  head/editors/libreoffice-uz/distinfo
  head/editors/libreoffice-ve/distinfo
  head/editors/libreoffice-vec/distinfo
  head/editors/libreoffice-xh/distinfo
  head/editors/libreoffice-zu/distinfo
  head/french/libreoffice/distinfo
  head/german/libreoffice/distinfo
  head/hebrew/libreoffice/distinfo
  head/hungarian/libreoffice/distinfo
  head/japanese/libreoffice/distinfo
  head/korean/libreoffice/distinfo
  head/polish/libreoffice/distinfo
  head/portuguese/libreoffice/distinfo
  head/portuguese/libreoffice-pt_BR/distinfo
  head/russian/libreoffice/distinfo
  head/ukrainian/libreoffice/distinfo
  head/vietnamese/libreoffice/distinfo
Comment 37 peo 2020-07-07 20:29:27 UTC
Updated from sources today including qt5- to 5.15.0 and LO to 6.4.5

% libreoffice

as before, blank pdf, few scattered characters in print

% env SAL_USE_VCLPLUGIN=kf5 libreoffice
% env SAL_VCL_QT5_USE_CAIRO=yes libreoffice

both works, no garbled area upon start
Comment 38 Tijl Coosemans freebsd_committer 2020-07-07 21:20:22 UTC
(In reply to peo from comment #37)
With 6.4.5 qt5+cairo should be the default so you should no longer need to set an environment variable.  Check with "svn status /usr/ports/editors/libreoffice" if you still have any local modifications from trying earlier patches.  You can restore a file using "svn revert /usr/ports/editors/libreoffice/....".
Comment 39 peo 2020-07-08 15:02:07 UTC
Yes, that fixed it!
Thanks,
Per
Comment 40 commit-hook freebsd_committer 2020-07-10 14:33:19 UTC
A commit references this bug:

Author: fluffy
Date: Fri Jul 10 14:33:05 UTC 2020
New revision: 541861
URL: https://svnweb.freebsd.org/changeset/ports/541861

Log:
  MFH: r541383

  Update LibreOffice suite to 6.4.5 release

  QT5 VCL fixes:
  - Reduce startup flickering
  - Always use cairo font renderer

  Special thanks to:	tijl

  PR:		247444

  Approved by:	ports-secteam (joneum)

Changes:
_U  branches/2020Q3/
  branches/2020Q3/arabic/libreoffice/distinfo
  branches/2020Q3/chinese/libreoffice-zh_CN/distinfo
  branches/2020Q3/chinese/libreoffice-zh_TW/distinfo
  branches/2020Q3/editors/libreoffice/Makefile.common
  branches/2020Q3/editors/libreoffice/distinfo
  branches/2020Q3/editors/libreoffice/files/patch-sc_source_core_opencl_formulagroupcl.cxx
  branches/2020Q3/editors/libreoffice/files/patch-sdext_source_pdfimport_xpdfwrapper_pdfioutdev__gpl.cxx
  branches/2020Q3/editors/libreoffice/files/patch-vcl_qt5_Qt5Frame.cxx
  branches/2020Q3/editors/libreoffice/files/patch-vcl_qt5_Qt5Instance.cxx
  branches/2020Q3/editors/libreoffice-af/distinfo
  branches/2020Q3/editors/libreoffice-am/distinfo
  branches/2020Q3/editors/libreoffice-as/distinfo
  branches/2020Q3/editors/libreoffice-ast/distinfo
  branches/2020Q3/editors/libreoffice-be/distinfo
  branches/2020Q3/editors/libreoffice-bg/distinfo
  branches/2020Q3/editors/libreoffice-bn/distinfo
  branches/2020Q3/editors/libreoffice-bn_IN/distinfo
  branches/2020Q3/editors/libreoffice-bo/distinfo
  branches/2020Q3/editors/libreoffice-br/distinfo
  branches/2020Q3/editors/libreoffice-brx/distinfo
  branches/2020Q3/editors/libreoffice-bs/distinfo
  branches/2020Q3/editors/libreoffice-ca/distinfo
  branches/2020Q3/editors/libreoffice-ca_valencia/distinfo
  branches/2020Q3/editors/libreoffice-cs/distinfo
  branches/2020Q3/editors/libreoffice-cy/distinfo
  branches/2020Q3/editors/libreoffice-da/distinfo
  branches/2020Q3/editors/libreoffice-dgo/distinfo
  branches/2020Q3/editors/libreoffice-dsb/distinfo
  branches/2020Q3/editors/libreoffice-dz/distinfo
  branches/2020Q3/editors/libreoffice-el/distinfo
  branches/2020Q3/editors/libreoffice-en_GB/distinfo
  branches/2020Q3/editors/libreoffice-en_ZA/distinfo
  branches/2020Q3/editors/libreoffice-eo/distinfo
  branches/2020Q3/editors/libreoffice-es/distinfo
  branches/2020Q3/editors/libreoffice-et/distinfo
  branches/2020Q3/editors/libreoffice-eu/distinfo
  branches/2020Q3/editors/libreoffice-fa/distinfo
  branches/2020Q3/editors/libreoffice-fi/distinfo
  branches/2020Q3/editors/libreoffice-fy/distinfo
  branches/2020Q3/editors/libreoffice-ga/distinfo
  branches/2020Q3/editors/libreoffice-gd/distinfo
  branches/2020Q3/editors/libreoffice-gl/distinfo
  branches/2020Q3/editors/libreoffice-gu/distinfo
  branches/2020Q3/editors/libreoffice-gug/distinfo
  branches/2020Q3/editors/libreoffice-hi/distinfo
  branches/2020Q3/editors/libreoffice-hr/distinfo
  branches/2020Q3/editors/libreoffice-hsb/distinfo
  branches/2020Q3/editors/libreoffice-id/distinfo
  branches/2020Q3/editors/libreoffice-is/distinfo
  branches/2020Q3/editors/libreoffice-it/distinfo
  branches/2020Q3/editors/libreoffice-ka/distinfo
  branches/2020Q3/editors/libreoffice-kab/distinfo
  branches/2020Q3/editors/libreoffice-kk/distinfo
  branches/2020Q3/editors/libreoffice-km/distinfo
  branches/2020Q3/editors/libreoffice-kmr_Latn/distinfo
  branches/2020Q3/editors/libreoffice-kn/distinfo
  branches/2020Q3/editors/libreoffice-kok/distinfo
  branches/2020Q3/editors/libreoffice-ks/distinfo
  branches/2020Q3/editors/libreoffice-lb/distinfo
  branches/2020Q3/editors/libreoffice-lo/distinfo
  branches/2020Q3/editors/libreoffice-lt/distinfo
  branches/2020Q3/editors/libreoffice-lv/distinfo
  branches/2020Q3/editors/libreoffice-mai/distinfo
  branches/2020Q3/editors/libreoffice-mk/distinfo
  branches/2020Q3/editors/libreoffice-ml/distinfo
  branches/2020Q3/editors/libreoffice-mn/distinfo
  branches/2020Q3/editors/libreoffice-mni/distinfo
  branches/2020Q3/editors/libreoffice-mr/distinfo
  branches/2020Q3/editors/libreoffice-my/distinfo
  branches/2020Q3/editors/libreoffice-nb/distinfo
  branches/2020Q3/editors/libreoffice-ne/distinfo
  branches/2020Q3/editors/libreoffice-nl/distinfo
  branches/2020Q3/editors/libreoffice-nn/distinfo
  branches/2020Q3/editors/libreoffice-nr/distinfo
  branches/2020Q3/editors/libreoffice-nso/distinfo
  branches/2020Q3/editors/libreoffice-oc/distinfo
  branches/2020Q3/editors/libreoffice-om/distinfo
  branches/2020Q3/editors/libreoffice-or/distinfo
  branches/2020Q3/editors/libreoffice-pa_IN/distinfo
  branches/2020Q3/editors/libreoffice-ro/distinfo
  branches/2020Q3/editors/libreoffice-rw/distinfo
  branches/2020Q3/editors/libreoffice-sa_IN/distinfo
  branches/2020Q3/editors/libreoffice-sat/distinfo
  branches/2020Q3/editors/libreoffice-sd/distinfo
  branches/2020Q3/editors/libreoffice-si/distinfo
  branches/2020Q3/editors/libreoffice-sid/distinfo
  branches/2020Q3/editors/libreoffice-sk/distinfo
  branches/2020Q3/editors/libreoffice-sl/distinfo
  branches/2020Q3/editors/libreoffice-sq/distinfo
  branches/2020Q3/editors/libreoffice-sr/distinfo
  branches/2020Q3/editors/libreoffice-sr_Latn/distinfo
  branches/2020Q3/editors/libreoffice-ss/distinfo
  branches/2020Q3/editors/libreoffice-st/distinfo
  branches/2020Q3/editors/libreoffice-sv/distinfo
  branches/2020Q3/editors/libreoffice-sw_TZ/distinfo
  branches/2020Q3/editors/libreoffice-szl/distinfo
  branches/2020Q3/editors/libreoffice-ta/distinfo
  branches/2020Q3/editors/libreoffice-te/distinfo
  branches/2020Q3/editors/libreoffice-tg/distinfo
  branches/2020Q3/editors/libreoffice-th/distinfo
  branches/2020Q3/editors/libreoffice-tn/distinfo
  branches/2020Q3/editors/libreoffice-tr/distinfo
  branches/2020Q3/editors/libreoffice-ts/distinfo
  branches/2020Q3/editors/libreoffice-tt/distinfo
  branches/2020Q3/editors/libreoffice-ug/distinfo
  branches/2020Q3/editors/libreoffice-uz/distinfo
  branches/2020Q3/editors/libreoffice-ve/distinfo
  branches/2020Q3/editors/libreoffice-vec/distinfo
  branches/2020Q3/editors/libreoffice-xh/distinfo
  branches/2020Q3/editors/libreoffice-zu/distinfo
  branches/2020Q3/french/libreoffice/distinfo
  branches/2020Q3/german/libreoffice/distinfo
  branches/2020Q3/hebrew/libreoffice/distinfo
  branches/2020Q3/hungarian/libreoffice/distinfo
  branches/2020Q3/japanese/libreoffice/distinfo
  branches/2020Q3/korean/libreoffice/distinfo
  branches/2020Q3/polish/libreoffice/distinfo
  branches/2020Q3/portuguese/libreoffice/distinfo
  branches/2020Q3/portuguese/libreoffice-pt_BR/distinfo
  branches/2020Q3/russian/libreoffice/distinfo
  branches/2020Q3/ukrainian/libreoffice/distinfo
  branches/2020Q3/vietnamese/libreoffice/distinfo