Bug 247604 - audio/audacity: Update to 2.4.2
Summary: audio/audacity: Update to 2.4.2
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Tobias Kortkamp
URL: https://www.audacityteam.org/audacity...
Keywords:
Depends on:
Blocks: 247481
  Show dependency treegraph
 
Reported: 2020-06-28 01:37 UTC by Jack
Modified: 2020-07-03 03:15 UTC (History)
2 users (show)

See Also:
koobs: maintainer-feedback+
koobs: merge-quarterly+


Attachments
Patch to upgrade audacity 2.4.1 to 2.4.2 (6.08 KB, patch)
2020-06-28 01:37 UTC, Jack
xxjack12xx: maintainer-approval+
Details | Diff
Updated patch to upgrade audacity to 2.4.2 (7.99 KB, patch)
2020-06-28 06:30 UTC, Jack
xxjack12xx: maintainer-approval+
Details | Diff
Upgrade audacity to 2.4.2 (6.64 KB, patch)
2020-07-01 05:50 UTC, Jack
xxjack12xx: maintainer-approval+
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Jack 2020-06-28 01:37:06 UTC
Created attachment 215999 [details]
Patch to upgrade audacity 2.4.1 to 2.4.2

Update audacity from 2.4.1 to 2.4.2 and fix startup hanging on FreeBSD 11.4
Comment 1 commit-hook freebsd_committer 2020-06-28 03:51:27 UTC
A commit references this bug:

Author: tobik
Date: Sun Jun 28 03:50:37 UTC 2020
New revision: 540665
URL: https://svnweb.freebsd.org/changeset/ports/540665

Log:
  audio/portaudio: Do not leak private libraries in portaudio-2.0.pc

  This prevents consumers from picking up bogus dependencies on
  libsndio when PortAudio has been built with SNDIO=on.

  PR:		247604

Changes:
  head/audio/portaudio/Makefile
  head/audio/portaudio/files/patch-portaudio-2.0.pc.in
Comment 2 Tobias Kortkamp freebsd_committer 2020-06-28 03:57:06 UTC
- Please remove bogus libsndio dependency
- cmake-proxies/CMakeLists.txt patch header is wrong. Please regen with
  make makepatch
- It fails to build in Poudriere: https://reviews.freebsd.org/P402
Comment 3 Jack 2020-06-28 06:30:11 UTC
Created attachment 216002 [details]
Updated patch to upgrade audacity to 2.4.2

make makepatch ran to fix headers on patches.
NYQUIST is required to build, remove optional knob.
Fix compilation error.
Comment 4 Tobias Kortkamp freebsd_committer 2020-06-29 03:56:39 UTC
It still failed to build with:

fatal error: file '/wrkdirs/usr/ports/audio/audacity/work/.build/src/private/configunix.h' has been modified since the precompiled header '/wrkdirs/usr/ports/audio/audacity/work/.build/src/CMakeFiles/Audacity.dir/cmake_pch.hxx.pch' was built
note: please rebuild precompiled header '/wrkdirs/usr/ports/audio/audacity/work/.build/src/CMakeFiles/Audacity.dir/cmake_pch.hxx.pch'

Just disabling precompiled headers via CMAKE_OFF=audacity_use_pch works though
so no need to dig deeper there IMO.

While the build on amd64 is now fixed there are still problems on i386:
https://reviews.freebsd.org/P403
Comment 5 Kubilay Kocak freebsd_committer freebsd_triage 2020-06-29 03:59:08 UTC
^Triage: [tags] in issue Titles are deprecated
Comment 6 Jack 2020-06-29 04:01:02 UTC
I guess I need to get a i386 machine working to see why it keeps failing on there. Will look into that.
Comment 7 Kubilay Kocak freebsd_committer freebsd_triage 2020-06-29 04:02:04 UTC
(In reply to Jack from comment #6)

poudriere can create i386 (or any arch) jails on a non-i386 host to test in that arch
Comment 8 Jack 2020-06-29 06:30:44 UTC
Looking at the build log
	/wrkdirs/usr/ports/audio/audacity/work/audacity-Audacity-2.4.2/lib-src/sbsms/src/fft.h:433:10: error: always_inline function '_mm_loadh_pi' requires target feature 'sse', but would be inlined into function 'execute' that is compiled without support for 'sse'

it sounds like that build system doesn't support sse? audacity requires sse but does i386 support sse? If not, then we're going to have to mark i386 as broken.
Comment 9 Tatsuki Makino 2020-06-29 22:02:14 UTC
(In reply to Jack from comment #8)

If the cause is sbsms, can't it be controlled by OPTIONS_EXCLUDE_${ARCH}?
Comment 10 Jack 2020-06-30 00:01:12 UTC
(In reply to Tatsuki Makino from comment #9)
Good idea, let me try that. Still need to set up i386 to test on there in case of other issues.
Comment 11 Jack 2020-07-01 05:50:13 UTC
Created attachment 216100 [details]
Upgrade audacity to 2.4.2

Remove SBSMS option for i386 as it requires sse.
Comment 12 Jack 2020-07-02 23:07:07 UTC
How does the current patch look?
Comment 13 Kubilay Kocak freebsd_committer freebsd_triage 2020-07-03 02:02:20 UTC
We should separate the i386 bugfix (and including any other fixes) from the version update, unless the version update is also bugfix-only, so that the former bugfixes changeset can be merged to the quarterly branch
Comment 14 Jack 2020-07-03 02:34:18 UTC
The old version is 2.4.1 and this patch upgrades the whole port to 2.4.2 which includes all the bug fixes.
Comment 15 commit-hook freebsd_committer 2020-07-03 02:59:17 UTC
A commit references this bug:

Author: tobik
Date: Fri Jul  3 02:58:50 UTC 2020
New revision: 541065
URL: https://svnweb.freebsd.org/changeset/ports/541065

Log:
  audio/audacity: Update to 2.4.2

  - This should fix hangs on startup on FreeBSD 11.4
  - Remove NYQUIST option since it is mandatory and disabling it does
    not work

  Changes:	https://www.audacityteam.org/audacity-2-4-2-released/
  PR:		247604
  Submitted by:	maintainer

Changes:
  head/audio/audacity/Makefile
  head/audio/audacity/distinfo
  head/audio/audacity/files/patch-cmake-proxies_CMakeLists.txt
  head/audio/audacity/files/patch-cmake-proxies_sbsms_CMakeLists.txt
  head/audio/audacity/files/patch-lib-src_libnyquist_nyquist_cmt_cext.h
  head/audio/audacity/files/patch-lib-src_libnyquist_nyquist_xlisp_xlisp.h
  head/audio/audacity/files/patch-src_AboutDialog.cpp
  head/audio/audacity/files/patch-src_AudioIO.cpp
  head/audio/audacity/files/patch-src_FFmpeg.h
  head/audio/audacity/pkg-plist
Comment 16 commit-hook freebsd_committer 2020-07-03 03:00:19 UTC
A commit references this bug:

Author: tobik
Date: Fri Jul  3 03:00:00 UTC 2020
New revision: 541066
URL: https://svnweb.freebsd.org/changeset/ports/541066

Log:
  MFH: r541065

  audio/audacity: Update to 2.4.2

  - This should fix hangs on startup on FreeBSD 11.4
  - Remove NYQUIST option since it is mandatory and disabling it does
    not work

  Changes:	https://www.audacityteam.org/audacity-2-4-2-released/
  PR:		247604
  Submitted by:	maintainer

  Approved by:	ports-secteam blanket

Changes:
_U  branches/2020Q3/
  branches/2020Q3/audio/audacity/Makefile
  branches/2020Q3/audio/audacity/distinfo
  branches/2020Q3/audio/audacity/files/patch-cmake-proxies_CMakeLists.txt
  branches/2020Q3/audio/audacity/files/patch-cmake-proxies_sbsms_CMakeLists.txt
  branches/2020Q3/audio/audacity/files/patch-lib-src_libnyquist_nyquist_cmt_cext.h
  branches/2020Q3/audio/audacity/files/patch-lib-src_libnyquist_nyquist_xlisp_xlisp.h
  branches/2020Q3/audio/audacity/files/patch-src_AboutDialog.cpp
  branches/2020Q3/audio/audacity/files/patch-src_AudioIO.cpp
  branches/2020Q3/audio/audacity/files/patch-src_FFmpeg.h
  branches/2020Q3/audio/audacity/pkg-plist
Comment 17 Kubilay Kocak freebsd_committer freebsd_triage 2020-07-03 03:15:12 UTC
^Triage: Track merge