Bug 248209 - shells/bash: Bash-5.0.18_2 from package returns "ld-elf.so.1: Undefined symbol "rl_signal_event_hook" referenced from COPY relocation in /usr/local/bin/bash"
Summary: shells/bash: Bash-5.0.18_2 from package returns "ld-elf.so.1: Undefined symbo...
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Emanuel Haupt
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-07-23 15:40 UTC by karl
Modified: 2020-07-24 06:29 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (ehaupt)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description karl 2020-07-23 15:40:33 UTC
This occurred following a recent update to the package.

Please revert.

$ bash
ld-elf.so.1: Undefined symbol "rl_signal_event_hook" referenced from COPY relocation in /usr/local/bin/bash
$ uname -v
FreeBSD 12.1-STABLE #7 r363092M: Sun Jul 12 16:42:48 EDT 2020     karl@NewFS.denninger.net:/usr/obj/usr/src/amd64.amd64/sys/KSD-SMP

$ pkg info bash
bash-5.0.18_2
Name           : bash
Version        : 5.0.18_2
Installed on   : Thu Jul 23 10:45:10 2020 EDT
Origin         : shells/bash
Architecture   : FreeBSD:12:amd64
Prefix         : /usr/local
Categories     : shells
Licenses       : GPLv3+
Maintainer     : ehaupt@FreeBSD.org
WWW            : https://www.gnu.org/software/bash/
Comment        : GNU Project's Bourne Again SHell
Options        :
        DOCS           : on
        FDESCFS        : off
        HELP           : on
        NLS            : on
        PORTS_READLINE : on
        STATIC         : off
        SYSBASHRC      : off
        SYSLOG         : off
Shared Libs required:
        libhistory.so.8
        libreadline.so.8
        libintl.so.8
Annotations    :
        FreeBSD_version: 1201000
        cpe            : cpe:2.3:a:gnu:bash:5.0.18:::::freebsd12:x64:2
        repo_type      : binary
        repository     : FreeBSD
Flat size      : 8.48MiB
Description    :
This is GNU Bash.  Bash is the GNU Project's Bourne Again SHell,
a complete implementation of the POSIX.2 shell spec, but also
with interactive command line editing, job control on architectures
that support it, csh-like features such as history substitution and
brace expansion, and a slew of other features.

WWW: https://www.gnu.org/software/bash/
Comment 1 Emanuel Haupt freebsd_committer 2020-07-23 16:08:32 UTC
So far I can't reproduce this. Could you please show me a list of your installed packages (pkg info -qo). I am assuming that you're building ports manually (not using packages). Is that correct? Does the error go away if you install the package (pkg install -f bash)?
Comment 2 Emanuel Haupt freebsd_committer 2020-07-23 16:11:39 UTC
Added requester of recent readline change.
Comment 3 karl 2020-07-23 16:13:32 UTC
(In reply to Emanuel Haupt from comment #1)

No, I am using packages on this machine, NOT building ports; that is why I flagged it here (if it was from ports I'd just go through and figure out what did it; best guess is that it's readline() related)

$ pkg info -qo|sort
archivers/brotli
archivers/libarchive
archivers/liblz4
archivers/lzo2
archivers/p7zip
archivers/pbzip2
archivers/php72-zlib
archivers/pixz
archivers/unzip
archivers/zip
archivers/zstd
audio/esound
audio/faac
audio/flac
audio/gstreamer1-plugins-a52dec
audio/gstreamer1-plugins-mpg123
audio/gstreamer1-plugins-ogg
audio/gstreamer1-plugins-vorbis
audio/id3lib
audio/id3mtag
audio/id3tool
audio/id3v2
audio/liba52
audio/libaudiofile
audio/libid3tag
audio/libogg
audio/libvorbis
audio/mp3info
audio/mpg123
audio/nas
audio/opus
audio/taglib
benchmarks/bonnie++
benchmarks/netperf
comms/qt5-sensors
comms/qt5-serialport
converters/base64
converters/fribidi
converters/libiconv
converters/p5-Encode-Detect
converters/p5-JSON
converters/p5-MIME-Base32
converters/php72-iconv
converters/php72-mbstring
converters/wkhtmltopdf
databases/db5
databases/gdbm
databases/lmdb
databases/mysql57-client
databases/mysql57-server
databases/p5-DBD-Pg
databases/p5-DBI
databases/p5-DBIx-Safe
databases/php72-pdo
databases/php72-pdo_mysql
databases/php72-pdo_pgsql
databases/php72-pgsql
databases/postgresql11-client
databases/qt5-sql
databases/rrdtool
databases/sqlite3
databases/tdb
devel/aarch64-none-elf-gcc
devel/apr1
devel/argp-standalone
devel/arm-none-eabi-gcc
devel/autoconf
devel/autoconf-wrapper
devel/automake
devel/binutils
devel/binutils
devel/binutils
devel/binutils
devel/bison
devel/boehm-gc
devel/boost-libs
devel/cmake
devel/cvsps
devel/dbus
devel/dbus-glib
devel/double-conversion
devel/evdev-proto
devel/gamin
devel/gccmakedep
devel/gettext
devel/gettext-runtime
devel/gettext-tools
devel/gflags
devel/git
devel/glib20
devel/glog
devel/gmake
devel/gnustep-make
devel/gobject-introspection
devel/icu
devel/imake
devel/jansson
devel/json-c
devel/jsoncpp
devel/libatomic_ops
devel/libcheck
devel/libconfuse
devel/libdaemon
devel/libdevq
devel/libedit
devel/libepoll-shim
devel/libevdev
devel/libevent
devel/libexecinfo
devel/libffi
devel/libffi321
devel/libftdi1
devel/libgudev
devel/libinotify
devel/libltdl
devel/libmtdev
devel/libpci
devel/libpciaccess
devel/libpthread-stubs
devel/libtextstyle
devel/libtool
devel/libudev-devd
devel/libunistring
devel/libunwind
devel/libuv
devel/m4
devel/makedepend
devel/nasm
devel/npth
devel/nspr
devel/oniguruma
devel/openmp
devel/orc
devel/p5-CPAN-Meta
devel/p5-Carp-Clan
devel/p5-Date-Calc
devel/p5-IO-Multiplex
devel/p5-Locale-gettext
devel/p5-Module-Build
devel/p5-Parse-Yapp
devel/p5-Proc-ProcessTable
devel/p5-Sub-Uplevel
devel/p5-Term-ReadKey
devel/p5-Test-Exception
devel/p5-TimeDate
devel/p5-subversion
devel/pcre
devel/pcre2
devel/php-libawl
devel/php72-gettext
devel/php72-json
devel/pkgconf
devel/popt
devel/protobuf
devel/py-evdev
devel/py-evdev
devel/py-iso8601
devel/py-ply
devel/py-ply
devel/py-pyudev
devel/py-pyudev
devel/py-setuptools
devel/py-setuptools
devel/py-six
devel/py-six
devel/qt5-concurrent
devel/qt5-core
devel/qt5-dbus
devel/qt5-location
devel/qt5-testlib
devel/re2c
devel/readline
devel/subversion
devel/t1lib
devel/talloc
devel/tevent
devel/vulkan-headers
devel/woff2
devel/xdg-utils
devel/xorg-macros
devel/yasm
dns/bind-tools
dns/bind916
dns/idnkit
dns/libidn
dns/libidn2
dns/p5-Net-DNS
dns/p5-Net-DNS-Resolver-Mock
dns/p5-Net-DNS-Resolver-Programmable
dns/p5-Net-LibIDN
dns/py-dnspython
emulators/mtools
emulators/qemu-user-static
emulators/tpm-emulator
ftp/curl
ftp/php72-curl
graphics/ImageMagick7-nox11
graphics/cairo
graphics/dcraw
graphics/fpc-libgd
graphics/freeglut
graphics/frei0r
graphics/gd
graphics/giflib
graphics/graphite2
graphics/gstreamer1-plugins-png
graphics/jasper
graphics/jbig2dec
graphics/jbigkit
graphics/jpeg-turbo
graphics/lcms
graphics/lcms2
graphics/leptonica
graphics/libGLU
graphics/libdrm
graphics/libexif
graphics/libfpx
graphics/liblqr-1
graphics/libmng
graphics/libraw
graphics/libwmf-nox11
graphics/mesa-libs
graphics/opencv
graphics/opencv-core
graphics/openjpeg
graphics/php72-gd
graphics/png
graphics/poppler-data
graphics/qt5-opengl
graphics/svgalib
graphics/tesseract
graphics/tesseract-data
graphics/tiff
graphics/wayland
graphics/webp
japanese/font-ipa
japanese/font-mplus-ipa
japanese/font-std
java/java-zoneinfo
lang/fpc
lang/gcc
lang/gcc-ecj45
lang/gcc8
lang/gcc9
lang/gnatcross-sysroot-aarch64
lang/libobjc2
lang/p5-Error
lang/perl5.30
lang/php72
lang/python
lang/python3
lang/python36
lang/python37
lang/ruby22
lang/ruby23
lang/ruby24
lang/ruby25
lang/ruby26
lang/spidermonkey17
mail/dovecot
mail/dovecot-pigeonhole
mail/p5-Mail-AuthenticationResults
mail/p5-Mail-DKIM
mail/p5-Mail-SPF
mail/p5-Mail-Tools
mail/panda-cclient
mail/pflogstats
mail/pflogsumm
mail/php72-imap
mail/postfix
mail/spamassassin
math/eigen2
math/fftw3
math/gmp
math/mpc
math/mpfr
math/p5-Bit-Vector
math/php72-gmp
misc/compat6x
misc/compat7x
misc/e2fsprogs-libuuid
misc/freebsd-release-manifests
misc/getopt
misc/help2man
misc/hicolor-icon-theme
misc/iso-codes
misc/mime-support
misc/pciids
misc/php72-calendar
misc/qtchooser
multimedia/aom
multimedia/dav1d
multimedia/ffmpeg
multimedia/gstreamer1
multimedia/gstreamer1-libav
multimedia/gstreamer1-plugins
multimedia/gstreamer1-plugins-bad
multimedia/gstreamer1-plugins-core
multimedia/gstreamer1-plugins-dts
multimedia/gstreamer1-plugins-dvdread
multimedia/gstreamer1-plugins-good
multimedia/gstreamer1-plugins-resindvd
multimedia/gstreamer1-plugins-theora
multimedia/gstreamer1-plugins-ugly
multimedia/libass
multimedia/libdca
multimedia/libdvdnav
multimedia/libdvdread
multimedia/libtheora
multimedia/libv4l
multimedia/libva
multimedia/libvdpau
multimedia/libvpx
multimedia/libx264
multimedia/mp4v2
multimedia/schroedinger
multimedia/v4l_compat
multimedia/x265
multimedia/xvid
net-mgmt/bsnmp-ucd
net-mgmt/cacti
net-mgmt/net-snmp
net-mgmt/p5-Net-IP
net-mgmt/p5-NetAddr-IP
net-mgmt/php72-snmp
net/avahi-app
net/mDNSResponder
net/openldap24-client
net/p5-IO-Socket-INET6
net/p5-IO-Socket-IP
net/p5-Net-CIDR-Lite
net/p5-Net-XWhois
net/p5-Socket
net/p5-Socket6
net/p5-URI
net/php72-ldap
net/php72-sockets
net/qt5-network
net/rsync
net/samba410
ports-mgmt/dialog4ports
ports-mgmt/pkg
ports-mgmt/poudriere
print/afm
print/cups
print/freetype2
print/ghostscript9-agpl-base
print/gsfonts
print/harfbuzz
print/indexinfo
print/libijs
print/libpaper
print/libraqm
print/psutils
print/qt5-printsupport
science/hdf5
science/szip
security/ca_root_nss
security/cyrus-sasl2
security/gnupg
security/gnupg1
security/gnutls
security/ipsec-tools
security/libargon2
security/libassuan
security/libgcrypt
security/libgpg-error
security/libksba
security/libtasn1
security/nettle
security/nmap
security/p11-kit
security/p5-Authen-SASL
security/p5-Crypt-OpenSSL-Bignum
security/p5-Crypt-OpenSSL-Guess
security/p5-Crypt-OpenSSL-RSA
security/p5-Crypt-OpenSSL-Random
security/p5-Digest-HMAC
security/p5-Digest-SHA1
security/p5-GSSAPI
security/p5-IO-Socket-SSL
security/p5-Net-SSLeay
security/php72-filter
security/php72-hash
security/php72-openssl
security/pinentry
security/pinentry-tty
security/pwauth
security/rhash
security/sshguard-ipfw
security/sshpass
security/sudo
security/trousers
shells/bash
sysutils/apcupsd
sysutils/beadm
sysutils/cmocka
sysutils/coreutils
sysutils/devcpu-data
sysutils/dmidecode
sysutils/etc_os-release
sysutils/flock
sysutils/gnome_subr
sysutils/hwstat
sysutils/libsunacl
sysutils/php72-posix
sysutils/pwgen
sysutils/rpi-firmware
sysutils/smartmontools
sysutils/u-boot-rpi2
sysutils/u-boot-rpi3
sysutils/zfs-stats
sysutils/zfstools
textproc/docbook-sgml
textproc/docbook-xml
textproc/expat2
textproc/flex
textproc/groff
textproc/gsed
textproc/hyphen
textproc/intltool
textproc/iso8879
textproc/libxml2
textproc/libxslt
textproc/libyaml
textproc/p5-Net-IDN-Encode
textproc/p5-Number-Format
textproc/p5-XML-Dumper
textproc/p5-XML-Parser
textproc/p5-YAML
textproc/p5-YAML-LibYAML
textproc/php72-ctype
textproc/php72-dom
textproc/php72-simplexml
textproc/php72-xml
textproc/php72-xmlwriter
textproc/php72-xsl
textproc/qt5-xmlpatterns
textproc/sdocbook-xml
textproc/uchardet
textproc/urlview
textproc/utf8proc
textproc/xmlcatmgr
textproc/xmlcharent
www/apache24
www/awstats
www/cadaver
www/libnghttp2
www/libwww
www/mod_php72
www/neon
www/p5-CGI
www/p5-HTML-Parser
www/p5-HTML-Tagset
www/p5-HTTP-Date
www/p5-Mozilla-CA
www/php72-session
www/qt5-webchannel
www/qt5-webkit
www/serf
www/w3m
x11-fonts/bitstream-vera
x11-fonts/dejavu
x11-fonts/encodings
x11-fonts/font-bh-ttf
x11-fonts/font-misc-ethiopic
x11-fonts/font-misc-meltho
x11-fonts/font-util
x11-fonts/fontconfig
x11-fonts/libXft
x11-fonts/libfontenc
x11-fonts/mkfontscale
x11-fonts/webfonts
x11-fonts/xorg-fonts-truetype
x11-themes/xcursor-themes
x11-toolkits/gstreamer1-plugins-pango
x11-toolkits/libXaw
x11-toolkits/libXmu
x11-toolkits/libXt
x11-toolkits/pango
x11-toolkits/qt5-declarative
x11-toolkits/qt5-gui
x11-toolkits/qt5-widgets
x11/libICE
x11/libSM
x11/libX11
x11/libXau
x11/libXcomposite
x11/libXdamage
x11/libXdmcp
x11/libXext
x11/libXfixes
x11/libXi
x11/libXp
x11/libXpm
x11/libXrandr
x11/libXrender
x11/libXv
x11/libXvMC
x11/libXxf86vm
x11/libinput
x11/libwacom
x11/libxcb
x11/libxkbcommon
x11/libxshmfence
x11/pixman
x11/xbitmaps
x11/xcb-proto
x11/xcb-util
x11/xcb-util-image
x11/xcb-util-keysyms
x11/xcb-util-renderutil
x11/xcb-util-wm
x11/xkeyboard-config
x11/xorg-cf-files
x11/xorg-docs
x11/xorgproto
x11/xprop
x11/xset
x11/xtrans
Comment 4 Tobias Kortkamp freebsd_committer 2020-07-23 16:26:33 UTC
This sure looks like the same issue as bug #245191 where the reporter still had
the obsolete /lib/libreadline.so.8 lying around after an incomplete base
update.
Comment 5 karl 2020-07-23 16:29:23 UTC
(In reply to Tobias Kortkamp from comment #4)

Aha.

Closed -- you are correct.
Comment 6 karl 2020-07-23 16:30:36 UTC
My apologies for not catching that...
Comment 7 commit-hook freebsd_committer 2020-07-24 06:29:25 UTC
A commit references this bug:

Author: ehaupt
Date: Fri Jul 24 06:28:50 UTC 2020
New revision: 543004
URL: https://svnweb.freebsd.org/changeset/ports/543004

Log:
  Amend bash entry from 20200716 with a solution for a know problem that occurs
  after an incomplete base update.

  PR:	248209 (motivated by)

Changes:
  head/UPDATING