Bug 248236 - graphics/gegl: g_random_* function always returns same random number sequence
Summary: graphics/gegl: g_random_* function always returns same random number sequence
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-gnome (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-07-24 05:30 UTC by Tatsuki Makino
Modified: 2020-08-14 07:21 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (gnome)


Attachments
patch to fix graphics/gegl (1.08 KB, patch)
2020-07-24 05:30 UTC, Tatsuki Makino
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Tatsuki Makino 2020-07-24 05:30:12 UTC
Created attachment 216736 [details]
patch to fix graphics/gegl

Random number sequence is always the same because the seed of g_random_* function is set to a fixed value.
It affects everything linked to libgegl.

For example:
mkdir ~/.config/GIMP/2.10/splashes
ln -s /usr/local/share/gimp/images/gimp-splash.png ~/.config/GIMP/2.10/splashes/
find ~/collection_of_cute_cats -type f -iname \*.jpg -print0 | xargs -0 -J % cp % ~/.config/GIMP/2.10/splashes/
gimp --new-instance &
gimp --new-instance &
gimp --new-instance &
gimp --new-instance &
gimp --new-instance &
Comment 1 VVD 2020-07-24 07:05:55 UTC
Is it upstream bug?
If yes, did you report it upstream?
Comment 2 Tatsuki Makino 2020-07-26 03:58:08 UTC
(In reply to VVD from comment #1)

Yes, probably upstream bug. But doesn't this happen in the Windows or Linux version of GIMP? That hasn't been pointed out yet.
And I have not yet reported this issue upstream. Additionally, I would like to ask someone to report on my behalf :) Because I have already used attachment 216736 [details] to make sure the problem is remedied, but I don't know if that's the right way to fix it. So could someone please inspect it and report it upstream?
Comment 3 Tatsuki Makino 2020-07-29 22:03:53 UTC
I correct my comment #2.
I sent an email to the developer within GEGL.
Comment 4 Tatsuki Makino 2020-07-30 11:43:42 UTC
The fix was applied upstream.
https://gitlab.gnome.org/GNOME/gegl/-/commit/8fbdf0c5637a7e7c72db944982c5afd0c1b9ceb6
After the next release, attachment 216736 [details] will no longer be required.
Comment 5 Tatsuki Makino 2020-08-14 07:21:50 UTC
gegl-0.4.26.tar.xz already exists.
It includes this fix.