Bug 248735 - devel/binutils: Fix build with -fno-common (clang 11 and gcc 10)
Summary: devel/binutils: Fix build with -fno-common (clang 11 and gcc 10)
Status: Closed DUPLICATE of bug 248701
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Baptiste Daroussin
URL:
Keywords:
Depends on:
Blocks: 248756
  Show dependency treegraph
 
Reported: 2020-08-18 21:11 UTC by Dimitry Andric
Modified: 2020-08-19 17:42 UTC (History)
2 users (show)

See Also:
bugzilla: maintainer-feedback? (bapt)


Attachments
Fix build with -fno-common (clang 11 and gcc 10) (3.86 KB, patch)
2020-08-18 21:11 UTC, Dimitry Andric
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Dimitry Andric freebsd_committer 2020-08-18 21:11:24 UTC
Created attachment 217320 [details]
Fix build with -fno-common (clang 11 and gcc 10)

In base r364284, I imported clang 11 into head. Like gcc 10, it now defaults to -fno-common, meaning that duplicated global symbols will most likely lead to link errors. Here is a patch to fix this port's duplicated global symbols.
Comment 1 Niclas Zeising freebsd_committer 2020-08-18 23:31:26 UTC

*** This bug has been marked as a duplicate of bug 248701 ***