Bug 248871 - emulators/simh-hp2100: fix pkg fallout (build problem)
Summary: emulators/simh-hp2100: fix pkg fallout (build problem)
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Many People
Assignee: Kyle Evans
URL:
Keywords: needs-qa
Depends on:
Blocks: 248756
  Show dependency treegraph
 
Reported: 2020-08-24 08:56 UTC by bob
Modified: 2020-08-29 02:12 UTC (History)
2 users (show)

See Also:
kevans: merge-quarterly+


Attachments
Proposed patch to be added to files/ (as a patch) (826 bytes, patch)
2020-08-24 08:56 UTC, bob
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description bob 2020-08-24 08:56:29 UTC
Created attachment 217481 [details]
Proposed patch to be added to files/ (as a patch)

This patch fixes the the current build failure caused by the default setting of -f-no-common in LLVM 11.

No deleted files; one new file (patch in files/).

Tested on LLVM 8 (12.1-RELEASE), LLVM 10 (13-CURRENT), and LLVM 11 (13-CURRENT, from ports) - all amd64.
Comment 1 bob 2020-08-24 08:57:56 UTC
PORTREVISION not bumped, as this is purely a build problem.
Comment 2 commit-hook freebsd_committer 2020-08-29 02:11:15 UTC
A commit references this bug:

Author: kevans
Date: Sat Aug 29 02:10:46 UTC 2020
New revision: 546863
URL: https://svnweb.freebsd.org/changeset/ports/546863

Log:
  emulators/simh-hp2100: fix the build with LLVM 11

  This patch adds -fcommon to the build flags to fix the build with LLVM 11,
  which now defaults to -fno-common.

  PR:		248871
  MFH:		2020Q3 (-fno-common build fix)

Changes:
  head/emulators/simh-hp2100/files/patch-SCP_makefile
Comment 3 commit-hook freebsd_committer 2020-08-29 02:12:16 UTC
A commit references this bug:

Author: kevans
Date: Sat Aug 29 02:11:27 UTC 2020
New revision: 546864
URL: https://svnweb.freebsd.org/changeset/ports/546864

Log:
  MFH: r546863

  emulators/simh-hp2100: fix the build with LLVM 11

  This patch adds -fcommon to the build flags to fix the build with LLVM 11,
  which now defaults to -fno-common.

  PR:		248871

  Approved by:	ports-secteam (implicit, -fno-common build fix)

Changes:
_U  branches/2020Q3/
  branches/2020Q3/emulators/simh-hp2100/files/patch-SCP_makefile
Comment 4 Kyle Evans freebsd_committer 2020-08-29 02:12:41 UTC
Committed, thanks!