Bug 249010 - USES=compiler:c11 breaks on MIPS due to unavailability of gcc9 at least on 12.1
Summary: USES=compiler:c11 breaks on MIPS due to unavailability of gcc9 at least on 12.1
Status: New
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Ports Framework (show other bugs)
Version: Latest
Hardware: mips Any
: --- Affects Only Me
Assignee: Port Management Team
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-08-30 08:15 UTC by Matthias Andree
Modified: 2020-08-30 08:15 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Matthias Andree freebsd_committer 2020-08-30 08:15:33 UTC
Ports using USES=compiler:c11, for instance, devel/libffi (needed for Python), imply lang/gcc9, which is set to IGNORE on MIPS, "is only for aarch64 amd64 arm armv6 armv7 i386 powerpc powerpc64 sparc64, while you are running mips64".

This prevents, among others, python (default 3.x version) and mail/fetchmailconf to be built.