Bug 249042 - lang/python37: Builds but fails to install
Summary: lang/python37: Builds but fails to install
Status: Closed DUPLICATE of bug 209355
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Kubilay Kocak
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-09-01 01:08 UTC by tech-lists
Modified: 2020-09-20 03:51 UTC (History)
3 users (show)

See Also:
dbaio: maintainer-feedback+
dbaio: maintainer-feedback? (tech-lists)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description tech-lists 2020-09-01 01:08:02 UTC
Hi,

context is 12.1-p8 & ports r547219

root@redacted /usr/ports/lang/python37# make -DBATCH install clean

[..builds...]

fails here:

install  -m 0644 /usr/ports/lang/python37/work/Python-3.7.9/Tools/gdb/libpython.py  /usr/ports/lang/python37/work/stage/usr/local/lib/libpython3.7m.so.1.0-gdb.py
====> Compressing man pages (compress-man)
===>  Installing for python37-3.7.9
===>  Checking if python37 is already installed
===>   Registering installation for python37-3.7.9
pkg-static: Unable to access file /usr/ports/lang/python37/work/stage/usr/local/lib/python3.7/lib-dynload/_lzma.so:No such file or directory
*** Error code 74

Stop.
make: stopped in /usr/ports/lang/python37
Comment 1 Danilo G. Baio freebsd_committer 2020-09-13 22:13:15 UTC
Hi.

Is this still happening?
If yes, could you send the full build log?
Comment 2 tech-lists 2020-09-14 12:25:11 UTC
(In reply to Danilo G. Baio from comment #1)

Yes it's still happening.

I updated my ports tree to 548578 and tried again:

# make clean distclean -DBATCH install

[...]

running install_scripts
copying build/scripts-3.7/idle3.7 -> /usr/ports/lang/python37/work/stage/usr/local/bin
copying build/scripts-3.7/pyvenv-3.7 -> /usr/ports/lang/python37/work/stage/usr/local/bin
copying build/scripts-3.7/pydoc3.7 -> /usr/ports/lang/python37/work/stage/usr/local/bin
copying build/scripts-3.7/2to3-3.7 -> /usr/ports/lang/python37/work/stage/usr/local/bin
changing mode of /usr/ports/lang/python37/work/stage/usr/local/bin/idle3.7 to 755
changing mode of /usr/ports/lang/python37/work/stage/usr/local/bin/pyvenv-3.7 to 755
changing mode of /usr/ports/lang/python37/work/stage/usr/local/bin/pydoc3.7 to 755
changing mode of /usr/ports/lang/python37/work/stage/usr/local/bin/2to3-3.7 to 755
rm /usr/ports/lang/python37/work/stage/usr/local/lib/python3.7/lib-dynload/_sysconfigdata_m_freebsd12_.py
rm -r /usr/ports/lang/python37/work/stage/usr/local/lib/python3.7/lib-dynload/__pycache__
install  -m 0644 ./Misc/python.man  /usr/ports/lang/python37/work/stage/usr/local/man/man1/python3.7.1
if test "xno" != "xno"  ; then  case no in  upgrade) ensurepip="--altinstall --upgrade" ;;  install|*) ensurepip="--altinstall" ;;  esac;  LD_LIBRARY_PATH=/usr/ports/lang/python37/work/Python-3.7.9 ./python -E -m ensurepip  $ensurepip --root=/usr/ports/lang/python37/work/stage/ ;  fi
/bin/rm -f /usr/ports/lang/python37/work/stage/usr/local/lib/libpython3.so                                              # Upstream Issue: https://bugs.python.org/issue17975
for i in /usr/ports/lang/python37/work/stage/usr/local/lib/python3.7/lib-dynload/*.so; do  /usr/bin/strip $i; done                  # Strip shared extensions
install  -m 0644 /usr/ports/lang/python37/work/Python-3.7.9/Tools/gdb/libpython.py  /usr/ports/lang/python37/work/stage/usr/local/lib/libpython3.7m.so.1.0-gdb.py
====> Compressing man pages (compress-man)
===>  Installing for python37-3.7.9
===>  Checking if python37 is already installed
===>   Registering installation for python37-3.7.9
pkg-static: Unable to access file /usr/ports/lang/python37/work/stage/usr/local/lib/python3.7/lib-dynload/_lzma.so:No such file or directory
*** Error code 74

Stop.
make: stopped in /usr/ports/lang/python37
#root:/usr/ports/lang/python37#

That comment in the output:

 # Upstream Issue: https://bugs.python.org/issue17975

that's from the build. I didn't add it. Haven't seen it before.
Comment 3 John Hein 2020-09-14 14:32:29 UTC
(In reply to tech-lists from comment #2)
That's not the full build log, but you can look at a log of a build upstream and compare to yours, and maybe figure out your problem.  Here's a recent successful one:

http://beefy4.nyi.freebsd.org/data/latest-per-pkg/python37/3.7.9/121i386-quarterly.log
Comment 4 tech-lists 2020-09-14 18:03:50 UTC
(In reply to John Hein from comment #3)

sorry I misread. I'll post (link) the full buildlog shortly
Comment 5 tech-lists 2020-09-14 20:57:26 UTC
(In reply to John Hein from comment #3)

ok ran it again like this:

# make clean distclean rmconfig rmconfig-recursive -DBATCH install > & /tmp/pythonbuildlog.txt

here's the full output:
https://cloud.zyxst.net/~john/FreeBSD/ports/buildfailures/pythonbuildlog.txt

I noticed this:

[snip]
building '_lzma' extension
cc -fPIC -Wno-unused-result -Wsign-compare -Wunreachable-code -DNDEBUG -O2 -pipe -fstack-protector-strong -fno-strict-aliasing -std=c99 -Wextra -Wno-unused-result -Wno-unused-parameter -Wno-missing-field-initializers -Wstrict-prototypes -Werror=implicit-function-declaration -I./Include -I. -I/usr/local/include -I/usr/ports/lang/python37/work/Python-3.7.9/Include -I/usr/ports/lang/python37/work/Python-3.7.9 -c /usr/ports/lang/python37/work/Python-3.7.9/Modules/_lzmamodule.c -o build/temp.freebsd-12.1-RELEASE-p9-amd64-3.7/usr/ports/lang/python37/work/Python-3.7.9/Modules/_lzmamodule.o
cc -pthread -shared -L/usr/local/lib -fstack-protector-strong -L/usr/local/lib -fstack-protector-strong -O2 -pipe -fstack-protector-strong -fno-strict-aliasing -I/usr/local/include -I/usr/local/include build/temp.freebsd-12.1-RELEASE-p9-amd64-3.7/usr/ports/lang/python37/work/Python-3.7.9/Modules/_lzmamodule.o -L. -L/usr/local/lib -llzma -lpython3.7m -o build/lib.freebsd-12.1-RELEASE-p9-amd64-3.7/_lzma.so
*** WARNING: renaming "_lzma" since importing it failed: build/lib.freebsd-12.1-RELEASE-p9-amd64-3.7/_lzma.so: Undefined symbol "lzma_check_is_supported"
[/snip]

maybe it ties up with this?

pkg-static: Unable to access file /usr/ports/lang/python37/work/stage/usr/local/lib/python3.7/lib-dynload/_lzma.so:No such file or directory

Maybe a libarchive problem? I don't know.
Comment 6 Danilo G. Baio freebsd_committer 2020-09-14 22:05:27 UTC
Thanks for the info.
same issue reported on bug 243817
I'll mark this PR as duplicate of it.

*** This bug has been marked as a duplicate of bug 243817 ***
Comment 7 Kubilay Kocak freebsd_committer freebsd_triage 2020-09-20 03:50:34 UTC

*** This bug has been marked as a duplicate of bug 209355 ***