Bug 249204 - archivers/xarchiver 0.5.4.15 fails in configure phase
Summary: archivers/xarchiver 0.5.4.15 fails in configure phase
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: amd64 Any
: --- Affects Only Me
Assignee: Danilo Egea Gondolfo
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-09-09 07:37 UTC by Marko Cupać
Modified: 2020-10-15 14:00 UTC (History)
0 users

See Also:
bugzilla: maintainer-feedback? (danilo)


Attachments
xarchiver.patch (1.31 KB, patch)
2020-10-09 09:01 UTC, Danilo Egea Gondolfo
no flags Details | Diff
xarchiver-0.5.4.15_1.log (121.73 KB, text/plain)
2020-10-14 06:31 UTC, Marko Cupać
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Marko Cupać 2020-09-09 07:37:03 UTC
Hi,

my poudriere won't build xarchiver 0.5.4.15, it fails in configure phase with the following message:

configure: error: xsltproc is required for rebuilding the pre-built documentation; consider --disable-doc

Perhaps this is because I have disabled DOCS globally in make.conf

Full log:

http://pkg.kappastar.com/data/12_1:x86:64-default-workstation/2020-09-09_09h23m08s/logs/errors/xarchiver-0.5.4.15.log

Regards,
Comment 1 Marko Cupać 2020-10-06 16:55:27 UTC
Any news regarding this issue?

Apparently problem has been introduced in latest Makefile revision, particularly the following line:

DOCS_USE=               GNOME=libxslt
Comment 2 Danilo Egea Gondolfo freebsd_committer 2020-10-09 09:01:58 UTC
Created attachment 218623 [details]
xarchiver.patch
Comment 3 Danilo Egea Gondolfo freebsd_committer 2020-10-09 09:03:22 UTC
Looks like the libtool files found in the tarball don't handle very well the disable-doc case. Regenerating them fixes the issue.

Can you test the attached patch?
Comment 4 Marko Cupać 2020-10-14 06:31:17 UTC
Created attachment 218728 [details]
xarchiver-0.5.4.15_1.log

xarchiver build log
Comment 5 Marko Cupać 2020-10-14 06:32:49 UTC
After applying your patch I can confirm xarchiver builds, installs and works fine even with DOCS disabled globally in make.conf.

I have added build log from poudriere as an attachment.

Thanks!
Comment 6 commit-hook freebsd_committer 2020-10-15 13:48:21 UTC
A commit references this bug:

Author: danilo
Date: Thu Oct 15 13:47:54 UTC 2020
New revision: 552416
URL: https://svnweb.freebsd.org/changeset/ports/552416

Log:
  archivers/xarchiver: Fix build with DOCS disabled. The configure script is not properly handling the case when docs is not enabled. Regenerating the autotools files before building fixes the issue.

  PR:		249204
  Reported by:	Marko Cupac

Changes:
  head/archivers/xarchiver/Makefile
  head/archivers/xarchiver/pkg-plist
Comment 7 Danilo Egea Gondolfo freebsd_committer 2020-10-15 14:00:11 UTC
Committed, thanks!