The current version (0.7.19_1) is 2 versions behind the latest version (0.8.0).
The single change that the new version seems to require is importlib-resources for versions of python <3.7.
NB: going to 0.8.0 changes the requirements, such that the port will no longer be available for 2.7. Not sure if that's an item of concern or not.
Upstream has not removed 2.7 from setup.py or added a python_requires precluding 2.7 at present, though I do see mention of these versions (2.7,3.5) to be considered unsupported.
 Python 2 versions older than 2.7 and Python 3 versions older than 3.5 should be considered unsupported. No incompatible code has been introduced to the best of our knowledge but there’s no CI infrastructure in place to verify this and if there are any issues with those versions they won’t be fixed.
Consequently, Python 2.7 and 3.5 support should be considered deprecated as 2.7 has reached its end-of-life already and 3.5 will hit it soon
As such I don't consider 0.8.x to be a hard removal of support, and will wait for explicit removal of support via python_requires or similar.
(In reply to Kubilay Kocak from comment #1)
The problem is that py-import-resources is incorrectly listed as only supporting python 3 in our port Makefile, despite the fact that it supposedly supports 2.7.
(In reply to Enji Cooper from comment #2)
The reason for this is that importlib-metadata depends on py-zipp which only supports 3.x, and if you don't mark importlib-metadata as only for python >3.x, you get other issues. Is a py27-netaddr really needed enough to require holding it back? Would creating a py-netaddr07 for the old version be OK?
With Pyhton 2.7 dependent ports being removed in the tree already it would make sense to move to 0.8 directly and remove 2.7 support?
(In reply to Franco Fichtner from comment #4)
0.8.0 is ok, but definitely mark the port broken for 2.7.
Turns out 0.7.20 is also implicitly reliant on py-import-resources, as I discovered with an ImportError today when executing the code on 2.7 >_>.