Bug 249399 - The last jail created using VNET has ARP problem
Summary: The last jail created using VNET has ARP problem
Status: Open
Alias: None
Product: Base System
Classification: Unclassified
Component: kern (show other bugs)
Version: 12.1-STABLE
Hardware: amd64 Any
: --- Affects Some People
Assignee: freebsd-net (Nobody)
URL:
Keywords:
: 249400 (view as bug list)
Depends on:
Blocks:
 
Reported: 2020-09-17 16:03 UTC by fred.ha11
Modified: 2020-09-29 22:39 UTC (History)
1 user (show)

See Also:


Attachments
/etc/jails.conf (5.34 KB, text/plain)
2020-09-17 16:03 UTC, fred.ha11
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description fred.ha11 2020-09-17 16:03:42 UTC
Created attachment 218028 [details]
/etc/jails.conf

12.2-BETA has a new issue with VNET that 12.1-RELEASE didn't have.

Initially when a list of jails are created all can be pinged. However, after the default ARP timeout, the last jail attached to the bridge fails to respond. If the ARP for the last jail is statically set (arp -s) it will again respond to pings. The problem only effects the last jail attached to the bridge regardless of the number of jails or which one is last.

My /etc/jails.conf is attached
Comment 1 fred.ha11 2020-09-17 18:34:03 UTC
*** Bug 249400 has been marked as a duplicate of this bug. ***
Comment 2 fred.ha11 2020-09-29 01:52:10 UTC
12.2-BETA3 does not have the problem. 

Closing the bug report as FIXED.
Comment 3 fred.ha11 2020-09-29 21:50:10 UTC
Re-opening this bug report as it has NOT been fixed in BETA3. I closed this ticket earlier as VNET work properly again on one of my test servers, unfortunately VNET still malfunctions on the second. 

OK, now we have a bug that will not always manifest itself, although the bugs behavior is consistent between reboots and always fails on the same server. The jail/vnet setup of both servers is similar but the number of running jails varies.

I would like to work with someone to fix this problem, but do not know what debug information to provide.

Symptoms:
-------------------------
(From the HOST) Initially when a list of jails are created all can be pinged. However, after the default ARP timeout, the LAST jail attached to the bridge fails to respond.

(From another jail attached to the same VNET) All jails including the last one created are pingable. Everything appears normal.
Comment 4 Bjoern A. Zeeb freebsd_committer 2020-09-29 22:39:04 UTC
Re-assign to net@ as the chances are much higher that network people can figure out ARP and things than jail people.