Bug 249752 - net/traefik: depends on python 2.x
Summary: net/traefik: depends on python 2.x
Status: Closed Overcome By Events
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Thomas Zander
URL:
Keywords:
Depends on:
Blocks: 249337
  Show dependency treegraph
 
Reported: 2020-09-24 16:34 UTC by Steve Wills
Modified: 2020-10-11 09:30 UTC (History)
0 users

See Also:
riggs: maintainer-feedback+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Steve Wills freebsd_committer 2020-09-24 16:34:06 UTC
This port will be removed on 2020-12-31 if not fixed
Comment 1 Thomas Zander freebsd_committer 2020-09-24 21:40:41 UTC
Python2 is not the only issue. To build the web-UI, it needs node8 :-)
The 1.7 branch is in maintenance mode anyway (receiving security fixes every now and then), and in all likelihood depreciation at the end of 2020 is in order. Will comment further when approaching the depreciation date.
Comment 2 Thomas Zander freebsd_committer 2020-10-11 09:30:57 UTC
Port was updated to upstream release 2.3.1.

(hey, I finally can get rid of my 2020Q1 ports branch :-) )