Bug 249782 - textproc/pup: depends on python 2.x
Summary: textproc/pup: depends on python 2.x
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Mateusz Piotrowski
URL:
Keywords:
Depends on:
Blocks: 249337
  Show dependency treegraph
 
Reported: 2020-09-24 16:36 UTC by Steve Wills
Modified: 2020-09-24 20:38 UTC (History)
0 users

See Also:
bugzilla: maintainer-feedback? (0mp)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Steve Wills freebsd_committer 2020-09-24 16:36:05 UTC
This port will be removed on 2020-12-31 if not fixed
Comment 1 Mateusz Piotrowski freebsd_committer 2020-09-24 18:48:47 UTC
Thanks for the heads-up, I'm on it.
Comment 2 commit-hook freebsd_committer 2020-09-24 20:38:25 UTC
A commit references this bug:

Author: 0mp
Date: Thu Sep 24 20:37:58 UTC 2020
New revision: 549950
URL: https://svnweb.freebsd.org/changeset/ports/549950

Log:
  Update to 0.4.0.10

  - Remove dependency on Python 2.7
  - Switch to Go modules
  - Drop the Go unit tests from do-test, the dependencies are not available

  PR:		249782

Changes:
  head/textproc/pup/Makefile
  head/textproc/pup/distinfo
Comment 3 Mateusz Piotrowski freebsd_committer 2020-09-24 20:38:52 UTC
Done, now the port can live without Python 2.7