Bug 249863 - [clang] SSE2 is enabled by default on amd64, but is not enabled by default on i386
Summary: [clang] SSE2 is enabled by default on amd64, but is not enabled by default on...
Status: Closed Not A Bug
Alias: None
Product: Base System
Classification: Unclassified
Component: misc (show other bugs)
Version: CURRENT
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-bugs (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-09-24 19:03 UTC by Yuri Victorovich
Modified: 2020-09-24 22:37 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yuri Victorovich freebsd_committer 2020-09-24 19:03:34 UTC
For example, the port misc/vxl r526931 fails on i386 because cmake can't find SSE2 enabled in the base compiler:
http://beefy17.nyi.freebsd.org/data/head-i386-default/p549547_s365984/logs/errors/vxl-2.0.2.629.log
but it normally succeeds on amd64 because SSE2 is enabled in the base compiler.

The defaults for SSE2 being enabled should be the same on both i386 and amd64 because the SSE status doesn't depend on the mode being 32-bit or 540-bit.
Comment 1 Yuri Victorovich freebsd_committer 2020-09-24 19:05:33 UTC
*64-bit
Comment 2 Conrad Meyer freebsd_committer 2020-09-24 19:57:27 UTC
This is correct.  SSE2 is a core instruction set feature on amd64, but is optional on ia32.
Comment 3 VVD 2020-09-24 22:35:32 UTC
Try to set CPUTYPE in /etc/make.conf.
Comment 4 Yuri Victorovich freebsd_committer 2020-09-24 22:37:57 UTC
(In reply to VVD from comment #3)

I asked this to troubleshoot port failures. Setting CPUTYPE in /etc/make.conf wouldn't be appropriate in this context, but thank you anyway. -)


Yuri