Bug 250005 - databases/cassandra3: Update to 3.11.8
Summary: databases/cassandra3: Update to 3.11.8
Status: Closed Overcome By Events
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Rene Ladan
URL: https://gitbox.apache.org/repos/asf?p...
Keywords:
: 248465 (view as bug list)
Depends on:
Blocks:
 
Reported: 2020-09-30 09:46 UTC by Angelo Polo
Modified: 2020-11-08 17:46 UTC (History)
4 users (show)

See Also:


Attachments
Patch to update to 3.11.8 (8.68 KB, patch)
2020-09-30 09:46 UTC, Angelo Polo
language.devel: maintainer-approval+
Details | Diff
Cassandra 3.11.8 update with Python 3.6+ support (9.12 KB, patch)
2020-10-04 15:28 UTC, Rainer Hurling
no flags Details | Diff
Update to 3.11.8 - remove REINPLACE_CMD (9.18 KB, patch)
2020-10-06 09:09 UTC, Angelo Polo
language.devel: maintainer-approval+
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Angelo Polo 2020-09-30 09:46:53 UTC
Created attachment 218434 [details]
Patch to update to 3.11.8

Update to version 3.11.8.
SVN patch attached.

See also bug #248465, which this update supersedes.

Updated maven repo must be manually copied to distfiles for patch testing and uploaded to LOCAL as part of the commit process. It is available at the following link:
https://drive.google.com/uc?id=1YCBzFX2hLhXy0zVNc8ziHF-3a_jetLQA&export=download
Comment 1 Angelo Polo 2020-09-30 09:48:23 UTC
*** Bug 248465 has been marked as a duplicate of this bug. ***
Comment 2 Lapo Luchini 2020-09-30 11:16:13 UTC
As a user of databases/cassandra3 in a production system, I hope the EXPIRATION_DATE can be moved forward a couple of months, as the final 4.0 release should be ready by then (databases/cassandra4 is currently a beta).
Comment 3 Fernando Apesteguía freebsd_committer 2020-10-01 07:21:10 UTC
^Triage: If there is a changelog or release notes URL available for this version, please add it to the URL field.

^Triage: Please set the maintainer-approval attachment flag (to +) on patches for ports you maintain to signify approval.
--
Attachment -> Details -> maintainer-approval [+]
Comment 4 Rainer Hurling freebsd_committer 2020-10-04 15:28:27 UTC
Created attachment 218522 [details]
Cassandra 3.11.8 update with Python 3.6+ support

Hmm, if I understand [1] correctly, Cassandra 3.11.x is able to use Python 3.6+. Because of this, I tried to build with 3.6+ instead of 2.7 and it builds and installs fine. 

Could you please try my attached patch with Python 3.6+ support and report back?

[1] https://cassandra.apache.org/doc/latest/getting_started/installing.html#prerequisites


BTW: make tells about two REINPLACE_CMDs, which seem to be NOPs:

====> Running Q/A tests (stage-qa)
Warning: Possible REINPLACE_CMD issues:
- - REINPLACE_CMD ran, but did not modify file contents: build/dist/bin/cqlsh
- - REINPLACE_CMD ran, but did not modify file contents: build/dist/conf/cassandra-env.sh
Comment 5 Angelo Polo 2020-10-05 08:55:36 UTC
(In reply to Rainer Hurling from comment #4)
The online documentation is built from trunk so it can't be relied upon in this context (see the header of the page https://cassandra.apache.org/doc/latest/). The corresponding line built from the cassandra-3.11 branch says "For using cqlsh, the latest version of Python 2.7."

I would prefer to keep this discussion separate from the issue of upgrading to 3.11.8. There are a bunch of relevant tickets with a fix version of 4.0 so it definitely deserves a closer look to make sure everything is working for 3.11.x. We already have bug #249595 for the python3 question where we can continue the discussion.

I'll take a look at the REINPLACE_CMD issue for this release.
Comment 6 Rainer Hurling freebsd_committer 2020-10-05 11:53:24 UTC
(In reply to Angelo Polo from comment #5)
> The online documentation is built from trunk so it can't be relied upon in this
> context (see the header of the page https://cassandra.apache.org/doc/latest/).
> The corresponding line built from the cassandra-3.11 branch says "For using
> cqlsh, the latest version of Python 2.7."

Thanks for the clarification. So for some reason the build and install seems fine, but with running cqlsh one should expect problems.

BTW: When I run 'cqlsh' the first message I get is

#cqlsh	
Warning: Timezone defined and 'pytz' module for timezone conversion not installed. Timestamps will be displayed in UTC timezone.

Does this mean that devel/py-pytz could be a needful dependency?


> I would prefer to keep this discussion separate from the issue of upgrading to
> 3.11.8. There are a bunch of relevant tickets with a fix version of 4.0 so it
> definitely deserves a closer look to make sure everything is working for 3.11.x. 
> We already have bug #249595 for the python3 question where we can continue the
> discussion.

Of course, I agree. 

But, is there any real chance to delay the deprecation of Python 2 and its dependencies a couple of month, as requested in comment #2?


> I'll take a look at the REINPLACE_CMD issue for this release.

Thanks.
Comment 7 Angelo Polo 2020-10-05 20:51:05 UTC
(In reply to Rainer Hurling from comment #6)
The timezone warning is from your python3 version though, right? I'm not seeing that... But thanks for the heads-up, I'll make a note to check on devel/py-pytz for bug #249595.

My understanding is that the deprecation of python2 is a pretty firm FreeBSD-wide thing that's going to happen. Anyway it's hung around too long already so I wouldn't be the one to advocate for yet another stay of execution ;)
Comment 8 Angelo Polo 2020-10-05 20:53:14 UTC
Comment on attachment 218522 [details]
Cassandra 3.11.8 update with Python 3.6+ support

This will be addressed separately from the upgrade to 3.11.8. See bug #249595.
Comment 9 Angelo Polo 2020-10-06 09:09:07 UTC
Created attachment 218553 [details]
Update to 3.11.8 - remove REINPLACE_CMD

This patch removes one of the replace commands (no longer necessary since CASSANDRA-14305 has been implemented).
The other one is because '/usr/share/cassandra' does not appear in the cqlsh script, but running the replacement is harmless (we'd want it replaced if it ever does pop up in that file) and I don't want to over-complicate things by looping over everything in SCRIPT_FILES except cqlsh (line 87).
Comment 10 Rene Ladan freebsd_committer 2020-11-08 17:46:33 UTC
Superceded by latest patch in 249595