Bug 250189 - upper USB port not working on pine64 with 12.2
Summary: upper USB port not working on pine64 with 12.2
Status: Open
Alias: None
Product: Base System
Classification: Unclassified
Component: arm (show other bugs)
Version: Unspecified
Hardware: arm64 Any
: --- Affects Only Me
Assignee: freebsd-arm (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-10-07 20:13 UTC by Vieno Hakkerinen
Modified: 2020-10-11 13:08 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Vieno Hakkerinen 2020-10-07 20:13:41 UTC
I wrote https://download.freebsd.org/ftp/releases/arm64/aarch64/ISO-IMAGES/12.2/FreeBSD-12.2-RC1-arm64-aarch64-PINE64.img.xz on a μSD card today and booted my pine64. I attached USB mass storages to both USB port. Sadly the USB dongle on the upper port was not recognized.

To verify that it is not a hardware problem I wrote armbian (based on Debian buster) to the same μSD card, booted and attached the same USB sticks. It worked.

I have not yet tried FreeBSD 13.
Comment 1 Vieno Hakkerinen 2020-10-11 12:22:40 UTC
I tried https://download.freebsd.org/ftp/releases/arm64/aarch64/ISO-IMAGES/12.2/FreeBSD-12.2-RC2-arm64-aarch64-PINE64.img.xz and it also does not recognize the USB mass storage in the upper USB port. Not even the LED on the USB stick is flashing.
Comment 2 Vieno Hakkerinen 2020-10-11 13:08:27 UTC
I am unable to test with https://download.freebsd.org/ftp/snapshots/arm64/aarch64/ISO-IMAGES/13.0/FreeBSD-13.0-CURRENT-arm64-aarch64-PINE64-20201001-e18fc94e525.img.xz as it ran in a kernel panic during boot.