Bug 250337 - security/py-asyncssh: update 1.6.1 -> 2.4.2
Summary: security/py-asyncssh: update 1.6.1 -> 2.4.2
Status: New
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Sunpoet Po-Chuan Hsieh
URL:
Keywords:
Depends on: 245929
Blocks:
  Show dependency treegraph
 
Reported: 2020-10-14 11:03 UTC by Kurt Jaeger
Modified: 2020-10-14 13:20 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (sunpoet)


Attachments
patch (832 bytes, patch)
2020-10-14 11:03 UTC, Kurt Jaeger
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Kurt Jaeger freebsd_committer 2020-10-14 11:03:39 UTC
Created attachment 218736 [details]
patch

While reading https://elegantnetwork.github.io/posts/comparing-ssh/
I found the ports needs an update.

Changelog: https://github.com/ronf/asyncssh/blob/master/docs/changes.rst

Testbuilds look fine. Probably needs run-tests.
Comment 1 Sunpoet Po-Chuan Hsieh freebsd_committer 2020-10-14 13:20:14 UTC
We have to wait for py-cryptography update.
I have submitted a patch for py-cryptography 2.7 (bug #238968) in order to update py-asyncssh 1.17.0 (bug #238969).
It now requires py-cryptography >= 2.8 [1].

Add bug #245929 (py-cryptography 2.9.2) to "Depends on".

[1] https://github.com/ronf/asyncssh/blob/v2.4.2/setup.py#L55