Bug 250800 - mail/postfixadmin: requires XMLRPC and thus fails to build with PHP 8.0
Summary: mail/postfixadmin: requires XMLRPC and thus fails to build with PHP 8.0
Status: Closed Overcome By Events
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-ports-bugs (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-11-02 08:56 UTC by Kamigishi Rei
Modified: 2021-04-09 17:00 UTC (History)
2 users (show)

See Also:
ports.maintainer: maintainer-feedback+


Attachments
Add PHP_VER awareness to xmlrpc inclusion (888 bytes, patch)
2020-11-09 10:38 UTC, Rin Morningstar
ports.maintainer: maintainer-approval+
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Kamigishi Rei 2020-11-02 08:56:55 UTC
XMLRPC was moved to PECL and is no longer available in base PHP. We may need a new port, www/pecl-xmlrpc or something like that. (Note: postfixadmin's XMLRPC functionality is an optional feature and does not seem to be required for its web interface to work.)
Comment 1 Rin Morningstar 2020-11-09 10:38:07 UTC
Created attachment 219484 [details]
Add PHP_VER awareness to xmlrpc inclusion

Add a basic PHP_VER test so the port only includes XMLRPC if we're building on PHP 7.x.  PHP 8 and PFA's IPC are mutually exclusive so the real fix will happen upstream.
Comment 2 Kamigishi Rei 2020-11-09 14:18:22 UTC
Upstream issue for reference: https://github.com/postfixadmin/postfixadmin/issues/395
Comment 3 Rin Morningstar 2020-11-19 09:56:13 UTC
Have you had time to test this patch? Do you get any other regressions with PFA on PHP 8?
Comment 4 Kamigishi Rei 2020-11-19 13:17:41 UTC
(In reply to Rin Morningstar from comment #3)
I was unable to properly test the port due to various other software's incompatibilities with PHP 8.0, but it now builds the package properly for 8.0 as well.
Comment 5 Rin Morningstar 2020-11-23 23:08:11 UTC
Approved for commit.

Tested here with no regressions on php74, submitter can build test on php80.  PFA is not definitely alone in being generally unproven on php80, but this change is required to make it possible for someone to build for it.
Comment 6 Kevin Bowling freebsd_committer 2021-04-08 21:33:01 UTC
It seems like a different and less robust fix was committed for just php80.  Can you rebase your patch, and investigate adding https://www.freshports.org/net/pecl-xmlrpc/ for >=php80?
Comment 7 Rin Morningstar 2021-04-09 13:35:08 UTC
ExecSum: no change needed, port works correctly by sheer luck, dead code will be trimmed later.  Close PR as FIXED.

When fluffy touched mail/postfixadmin back in December, they ignored this PR.  The commit message included a note about me having two months to "react and fix" php80 support.  That was more than a month after this PR was approved for commit.

The change fluffy made tested FLAVOR in an unflavoured port.  That would have resulted in a no-op change, but they also made a typo and wrote "USE_PHP_=" instead of "USE_PHP+=".  This dropped xmlrpc support for all versions of PHP, yielding a shallow positive result of letting the port build with php80.

The port then sat until 2 March, when portmgr fixed the USE_PHP_ typo but didn't correct FLAVOR to PHP_VER, turning fluffy's change into a no-op and adding xmlrpc to USE_PHP for all PHP versions, breaking the build for php80.

On 28 March, net/pecl-xmlrpc was added and the Uses framework was updated to correctly choose between net/php*-xmlrpc or net/pecl-xmlrpc depending on PHP_VER, making the port once again build for all versions of PHP.

Other than this PR, no one mentioned PostfixAdmin not building for php80.  Nor did anyone complain about missing XML-RPC support.

In a later update, I revert the USE_PHP bits to how they were with r535201.

FWIW, XML-RPC support in PostfixAdmin is moribund.  See issue #395 on the Github: https://github.com/postfixadmin/postfixadmin/issues/395

If you do need XML-RPC support, please mention it on Github and say what you're using it for. The only thing I know of that used it was a password-change plugin for the long-defunct Squirrelmail webmail app.

At this point, this PR can be closed FIXED due to externalities.
Comment 8 Kevin Bowling freebsd_committer 2021-04-09 17:00:43 UTC
(In reply to Rin Morningstar from comment #7)
Sorry for the runaround you experienced here.  I am happy to help if you tag me in the future on ports issues.

I agree with your assessment.  I know of no other usage of the xmlrpc, just saw the plugin you mentioned with a quick google search when I was looking at moving this PR along so I'd recommend dropping any support of it from the port in a future update given php already has a wide attack area, no need to increase it further.