Bug 251479 - www/privoxy: Update to 3.0.29
Summary: www/privoxy: Update to 3.0.29
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: freebsd-ports-bugs (Nobody)
URL: https://www.privoxy.org/announce.txt
Keywords: buildisok
Depends on:
Blocks:
 
Reported: 2020-11-30 10:57 UTC by Fabian Keil
Modified: 2021-01-17 18:17 UTC (History)
1 user (show)

See Also:
fernape: merge-quarterly+


Attachments
www/privoxy: Update to 3.0.29 (5.70 KB, patch)
2020-11-30 10:57 UTC, Fabian Keil
fk: maintainer-approval+
Details | Diff
www/privoxy: Update to 3.0.29 and sort variables (6.41 KB, patch)
2020-12-08 12:40 UTC, Fabian Keil
fk: maintainer-approval+
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Fabian Keil 2020-11-30 10:57:01 UTC
Created attachment 220101 [details]
www/privoxy: Update to 3.0.29

The attached patch updates www/privoxy to 3.0.29 which fixes a
couple of memory leaks and introduces https inspection which
allows to filter encrypted requests and responses.
    
The upstream changes are documented at:
https://www.privoxy.org/announce.txt
    
Port changes:
- Add support for https inspection and Brotli.
- Let Privoxy serve the manual itself again when docs are enabled.
- Enable ACCEPT_FILTER by default.
- Set the listen-backlog directive to -1.
- Change WWW to https.
- Include url-pattern-translator.pl when building with PRIVOXY_TOOLS.

Portlint complaints that '"BROKEN_STRPTIME_DESC" has to appear earlier.'
but that seems to be false positive.
Comment 1 Automation User 2020-11-30 16:17:59 UTC
Build and package info is available at https://gitlab.com/swills/freebsd-ports/pipelines/223073521
Comment 2 Fernando Apesteguía freebsd_committer 2020-11-30 19:08:09 UTC
^Triage: If there is a changelog or release notes URL available for this version, please add it to the URL field.

^Triage: Please set the maintainer-approval attachment flag (to +) on patches for ports you maintain to signify approval.
--
Attachment -> Details -> maintainer-approval [+]

^Triage: Maintainer-feedback flag (+) not required unless requested (?) first.

Q/A:  Makefile: Consider defining LICENSE. (Privoxy is Free Software and licensed under the GNU GPLv2 or later.)

^Triage: Please confirm this change passes QA (portlint, poudriere at least).
--
https://www.freebsd.org/doc/en/books/porters-handbook/testing.html


Thanks!
Comment 3 Fabian Keil 2020-12-07 16:33:22 UTC
Thanks for the review and the comments.

I can confirm that the patch passes a "poudriere testport" build.

As mentioned in the description, portlint complaints that
'"BROKEN_STRPTIME_DESC" has to appear earlier.' but that
seems to be false positive.

I intentionally don't use the undocumented LICENSE "framework",
for details please see:
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=195807 and
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=187926

If you feel the need to force a LICENSE tag on the port,
please relieve me as maintainer.

Note that the port contains more than just the privoxy
binary so the content isn't 100% GNU GPLv2 or later.
Comment 4 Fernando Apesteguía freebsd_committer 2020-12-07 17:22:33 UTC
(In reply to Fabian Keil from comment #3)
Hi Fabian,

Thanks for the clarification. No, I will not force you to add a LICENSE (or anything for that matter).

The port could use some clean up though. Some variables are out of place (SHEBANG_FILES should appear before CONFIGURE_* stuff, USE_RC_SUBR is better in the USES block, CPP/LDFLAGS should be after the MAKEFILE block..)

For stuff like that, portclippy usually does a better job than portlint... but none of them replace good judgement :-)
Comment 5 Fabian Keil 2020-12-08 12:40:12 UTC
Created attachment 220367 [details]
www/privoxy: Update to 3.0.29 and sort variables

Thanks for pointing out portclippy.

I've sorted the Makefile variables so portclippy is silent.
Comment 6 Fabian Keil 2021-01-16 12:59:57 UTC
Ping.
Comment 7 commit-hook freebsd_committer 2021-01-17 18:15:13 UTC
A commit references this bug:

Author: fernape
Date: Sun Jan 17 18:14:23 UTC 2021
New revision: 561850
URL: https://svnweb.freebsd.org/changeset/ports/561850

Log:
  www/privoxy: Update to 3.0.29

  ChangeLog: https://www.privoxy.org/announce.txt

  PR:	251479
  Submitted by:	fk@fabiankeil.de (maintainer)
  MFH:	2021Q1 (multiple bug fixes)

Changes:
  head/www/privoxy/Makefile
  head/www/privoxy/distinfo
  head/www/privoxy/pkg-descr
  head/www/privoxy/pkg-plist
Comment 8 commit-hook freebsd_committer 2021-01-17 18:17:15 UTC
A commit references this bug:

Author: fernape
Date: Sun Jan 17 18:17:08 UTC 2021
New revision: 561852
URL: https://svnweb.freebsd.org/changeset/ports/561852

Log:
  MFH: r561850

  www/privoxy: Update to 3.0.29

  ChangeLog: https://www.privoxy.org/announce.txt

  PR:	251479
  Submitted by:	fk@fabiankeil.de (maintainer)

Changes:
_U  branches/2021Q1/
  branches/2021Q1/www/privoxy/Makefile
  branches/2021Q1/www/privoxy/distinfo
  branches/2021Q1/www/privoxy/pkg-descr
  branches/2021Q1/www/privoxy/pkg-plist
Comment 9 Fernando Apesteguía freebsd_committer 2021-01-17 18:17:45 UTC
Committed and merged to 2021Q1,

Thanks!