Bug 251898 - x11/screenkey: Update to 1.3
Summary: x11/screenkey: Update to 1.3
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Alexey Dokuchaev
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-12-16 18:42 UTC by Neel Chauhan
Modified: 2021-01-25 02:53 UTC (History)
0 users

See Also:
bugzilla: maintainer-feedback? (danfe)


Attachments
Patch (Revision 1) (809 bytes, patch)
2020-12-16 18:42 UTC, Neel Chauhan
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Neel Chauhan freebsd_committer 2020-12-16 18:42:56 UTC
Created attachment 220635 [details]
Patch (Revision 1)

Passes poudriere.
Comment 1 Alexey Dokuchaev freebsd_committer 2020-12-17 02:48:25 UTC
Thank for the patch.  Version 1.3 gives me the following warning during run-time, which I do not observe with 1.2 and which probably ought to be investigated and fixed before updating:

> /usr/local/lib/python3.7/site-packages/Screenkey/screenkey.py:438: Warning:
> Source ID 224 was not found when attempting to remove it
>   GObject.source_remove(self.timer_hide)
Did you see anything like that?
Comment 2 Alexey Dokuchaev freebsd_committer 2021-01-25 02:00:37 UTC
(In reply to Alexey Dokuchaev from comment #1)
> Version 1.3 gives me the following warning during run-time [...]
I cannot reproduce this with recently released version 1.4, so I'll be updating to it shortly.
Comment 3 commit-hook freebsd_committer 2021-01-25 02:51:06 UTC
A commit references this bug:

Author: danfe
Date: Mon Jan 25 02:50:09 UTC 2021
New revision: 562526
URL: https://svnweb.freebsd.org/changeset/ports/562526

Log:
  Update to version 1.4.

  Reported by:	portscout
  PR:		251898

Changes:
  head/x11/screenkey/Makefile
  head/x11/screenkey/distinfo