Bug 252288 - print/py-reportlab: py37-reportlab-3.5.57 upgrade fails on userguide.pdf
Summary: print/py-reportlab: py37-reportlab-3.5.57 upgrade fails on userguide.pdf
Status: Closed Unable to Reproduce
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: arm64 Any
: --- Affects Only Me
Assignee: Muhammad Moinur Rahman
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-12-30 14:28 UTC by pcc
Modified: 2021-01-26 23:28 UTC (History)
0 users

See Also:
bugzilla: maintainer-feedback? (bofh)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description pcc 2020-12-30 14:28:23 UTC
G'day,

On ...

FreeBSD rpi4 13.0-CURRENT FreeBSD 13.0-CURRENT #0 r368820: Sun Dec 20 23:25:08 UTC 2020     root@rpi4:/usr/obj/usr/src/arm64.aarch64/sys/GENERIC  arm64

..., with DOCS enabled, ...

# This file is auto-generated by 'make config'.
# Options for py37-reportlab-3.5.55
_OPTIONS_READ=py37-reportlab-3.5.55
_FILE_COMPLETE_OPTIONS_LIST=CJK DOCS FREETYPE
OPTIONS_FILE_SET+=CJK
OPTIONS_FILE_SET+=DOCS
OPTIONS_FILE_SET+=FREETYPE

..., when I last attempted to upgrade via ports, updating from py37-reportlab-3.5.55 to py37-reportlab-3.5.57 failed since userguide.pdf was not created. A manual ...

mkdir -p /usr/local/lib/python3.7/site-packages/docs/userguide ; ( cd /usr/ports/print/py-reportlab/work-py37/reportlab-3.5.57/docs/userguide/ && python3.7 genuserguide.py )

... sufficed for the subsequent ...

make all deinstall-all reinstall package clean

... to succeed.

Cheers,

Peter.
Comment 1 Muhammad Moinur Rahman freebsd_committer 2021-01-26 23:28:17 UTC
I am not sure about the exact reason. I checked my build logs and found that it's built properly. For your reference you can check the logs.
http://pdr.bofh.network/data/latest-per-pkg/py37-reportlab/3.5.57/122amd64-default.log

However I am updating py-reportlab to 3.5.60 within couple of hours.