Bug 253079 - assert panic when mounting smb share
Summary: assert panic when mounting smb share
Status: Closed FIXED
Alias: None
Product: Base System
Classification: Unclassified
Component: kern (show other bugs)
Version: CURRENT
Hardware: arm64 Any
: --- Affects Only Me
Assignee: Brooks Davis
URL:
Keywords: panic
: 258421 258477 (view as bug list)
Depends on:
Blocks:
 
Reported: 2021-01-29 14:07 UTC by Alfredo Dal'Ava Junior
Modified: 2021-10-20 18:04 UTC (History)
3 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alfredo Dal'Ava Junior freebsd_committer 2021-01-29 14:07:32 UTC
I hit a assertion panic while trying to mount a SMB share over network, 100% of times on Raspberry Pi 3B.
Unfortunately I can't give more information about exact setup, versions and mount command at this moment, will add this information later.

Partial crash data retrieved from a picture taken from the screen:



panic: Assertion stp->st_flags == 0 failed at /usr/src/sys/kern/sys_generic:1960
..
..
panic() at seltdfini+0x44
..
..
seltdini() at exit1+0xa8
..
..
exit1() at smb_iod_thread+0x380
..
..
kproc_exit() at fork_exist+0x7c
Comment 1 Mark Johnston freebsd_committer 2021-10-16 21:45:05 UTC
*** Bug 258477 has been marked as a duplicate of this bug. ***
Comment 2 Mark Johnston freebsd_committer 2021-10-16 21:45:20 UTC
*** Bug 258421 has been marked as a duplicate of this bug. ***
Comment 3 Mark Johnston freebsd_committer 2021-10-16 21:46:00 UTC
This should be fixed by https://cgit.freebsd.org/src/commit/?id=04c91ac48ad13ce0d1392cedbd69c2c0223d206f
Comment 4 commit-hook freebsd_committer 2021-10-19 23:21:22 UTC
A commit in branch stable/13 references this bug:

URL: https://cgit.FreeBSD.org/src/commit/?id=3b55b6137195ee116680590c1d3c4416a88fee2e

commit 3b55b6137195ee116680590c1d3c4416a88fee2e
Author:     Brooks Davis <brooks@FreeBSD.org>
AuthorDate: 2021-10-19 23:19:57 +0000
Commit:     Brooks Davis <brooks@FreeBSD.org>
CommitDate: 2021-10-19 23:19:57 +0000

    selsocket: handle sopoll() errors correctly

    Without this change, unmounting smbfs filesystems with an INVARIANTS
    kernel would panic after 10e64782ed59727e8c9fe4a5c7e17f497903c8eb.

    PR:             253079
    Found by:       markj
    Reviewed by:    markj, jhb
    Obtained from:  CheriBSD
    Sponsored by:   DARPA
    Differential Revision:  https://reviews.freebsd.org/D32492

    (cherry picked from commit 04c91ac48ad13ce0d1392cedbd69c2c0223d206f)

 sys/kern/sys_generic.c | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)
Comment 5 commit-hook freebsd_committer 2021-10-20 16:01:25 UTC
A commit in branch stable/12 references this bug:

URL: https://cgit.FreeBSD.org/src/commit/?id=2f022558ce3d00eb53fd235dd87db780acd9bc25

commit 2f022558ce3d00eb53fd235dd87db780acd9bc25
Author:     Brooks Davis <brooks@FreeBSD.org>
AuthorDate: 2021-10-20 16:00:38 +0000
Commit:     Brooks Davis <brooks@FreeBSD.org>
CommitDate: 2021-10-20 16:00:38 +0000

    selsocket: handle sopoll() errors correctly

    Without this change, unmounting smbfs filesystems with an INVARIANTS
    kernel would panic after 10e64782ed59727e8c9fe4a5c7e17f497903c8eb.

    PR:             253079
    Found by:       markj
    Reviewed by:    markj, jhb
    Obtained from:  CheriBSD
    Sponsored by:   DARPA
    Differential Revision:  https://reviews.freebsd.org/D32492

    (cherry picked from commit 04c91ac48ad13ce0d1392cedbd69c2c0223d206f)

 sys/kern/sys_generic.c | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)
Comment 6 Brooks Davis freebsd_committer 2021-10-20 18:04:27 UTC
Should be fixed on main, stable/12, and stable/13.