Bug 253358 - 13.0-BETA1: Complete system hang on ThinkPad X1 Carbon Gen7
Summary: 13.0-BETA1: Complete system hang on ThinkPad X1 Carbon Gen7
Status: Closed DUPLICATE of bug 253288
Alias: None
Product: Base System
Classification: Unclassified
Component: misc (show other bugs)
Version: 13.0-STABLE
Hardware: amd64 Any
: --- Affects Some People
Assignee: freebsd-bugs (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-02-08 21:42 UTC by Sreehari S
Modified: 2021-02-09 07:53 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sreehari S 2021-02-08 21:42:33 UTC
I just installed 13.0-BETA1 on my ThinkPad with mostly default options (wifi connectivity, zfs root), and during the bootup right after installation the system just hangs completely with absolutely no warning or any indication other than the system not responding to anything. I also tried 13.0-BETA1 yesterday and even went as far as installing sway and firefox, but that crashed during usage too and I was suspecting some wayland or graphics bug so today I did a clean install and it crashed even without drm-kmod installation so I think that's ruled out. All I know now is that these system crashes are completely random and can happen at any time or just not happen at all possibly. Way back in the past I've even tried booting 13.0-CURRENT on this machine but it had this exact same issue of random crashes, and I just assumed that was something to do with running pre release software (I'm no expert on FreeBSD). I have an upload to bsd-hardware.info from yesterday available here: http://bsd-hardware.info/?probe=77e80759a0. In addition, I made a new hw-probe today available here (in case there's any real difference, I have no clue): http://bsd-hardware.info/?probe=8d1c80c2cb. I made this upload on a second boot without running into a complete system hang, though it might just happen later. Again I've got absolutely no clue what could be causing the system crash since I don't even get an error. It seems even SSH connections to the laptop hang, so it's not just a graphics bug or something as far as I know.
Comment 1 Sreehari S 2021-02-08 21:49:54 UTC
Oh yeah it's probably important to mention but I haven't faced this issue at all on 12.1 or 12.2 or anything before 13.0 really on this exact hardware
Comment 2 Conrad Meyer freebsd_committer 2021-02-09 07:53:35 UTC
This seems to crop up only on Lenovo systems for some reason.  See workaround in bug 253288.

*** This bug has been marked as a duplicate of bug 253288 ***