Bug 253570 - x11/cinnamon: Does not work with an AMD GPU?
Summary: x11/cinnamon: Does not work with an AMD GPU?
Status: Closed Overcome By Events
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-gnome (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-02-16 21:58 UTC by Alexander Vereeken
Modified: 2021-02-21 21:27 UTC (History)
3 users (show)

See Also:
bugzilla: maintainer-feedback? (gnome)


Attachments
glx_disable_ext_buffer_age (1.03 KB, patch)
2021-02-20 04:51 UTC, Charlie Li
ml+freebsd: maintainer-approval? (x11)
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Vereeken 2021-02-16 21:58:53 UTC
Hello,

when i start cinnamon start normally then i see the desktop but freezes directly. 

But when i start cinnamon with software renderer then it works.

With the normal gnome desktop this seems to be the same case.

GPU: AMD Radeon RX 570 using drm-kmod from ports with FreeBSD 12.2-STABLE r369250
Comment 1 Patricio Villar 2021-02-20 02:24:29 UTC
Hi, I also had that issue with Intel HD 5500 graphics with drm-fbsd13-kmod and modesetting driver.
However, installing the (supposedly deprecated?) xf86-video-intel driver solved the problem...
Not sure about your AMD graphics though :(
Comment 2 Charlie Li 2021-02-20 04:36:51 UTC
The issue with Intel modesetting is caused by something in the iris DRI/Gallium driver not agreeing with our graphics subsystem. xf86-video-intel is also affected if iris is used. See bug 251836.

Unfortunately, not sure about the AMD graphics issue, as I don't have any AMD graphics hardware.
Comment 3 Charlie Li 2021-02-20 04:51:12 UTC
Created attachment 222656 [details]
glx_disable_ext_buffer_age

Disable buffer_age for x11/cinnamon on iris. This is a follow-up to bug 251836 that I forgot to add to the original Cinnamon update.

Note that this does not fix the original issue reported, which happens on AMD graphics hardware.
Comment 4 Alexander Vereeken 2021-02-21 18:14:00 UTC
Its a x11-wm/mutter issue. Because i can reproduce the problem when using mutter standalone.

PR 253746 have been created for that issue.

How to close this issue correctly?
Comment 5 Mark Linimon freebsd_committer freebsd_triage 2021-02-21 20:16:44 UTC
^Triage: closed at submitter's request.
Comment 6 Charlie Li 2021-02-21 21:27:53 UTC
(In reply to Alexander Vereeken from comment #4)
> Its a x11-wm/mutter issue.
Cinnamon doesn't use Mutter. Further, Muffin, which forked from Mutter, is only linked and not ran directly. Thus, fixes on Mutter will need ported here, to x11/cinnamon, as well.