Bug 253729 - graphics/libheif: Change build to include example programs
Summary: graphics/libheif: Change build to include example programs
Status: Closed DUPLICATE of bug 245387
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Mark Felder
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-02-20 20:10 UTC by Mark Felder
Modified: 2021-03-23 22:23 UTC (History)
3 users (show)

See Also:
bugzilla: maintainer-feedback? (freebsd)


Attachments
include example programs (3.24 KB, patch)
2021-02-20 20:10 UTC, Mark Felder
no flags Details | Diff
fixed (3.12 KB, patch)
2021-02-20 20:15 UTC, Mark Felder
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Mark Felder freebsd_committer 2021-02-20 20:10:48 UTC
Created attachment 222687 [details]
include example programs

This patch switches the build from cmake to automake so the example programs are built. The build was already setting CMAKE_OFF=WITH_EXAMPLES but that setting doesn't do anything. It appears building the example programs are completely broken with their cmake build framework.


background:


libheif comes with examples programs which are packaged together or as a subpackage in other OSes:

bin/heif-convert
bin/heif-enc
bin/heif-info
bin/heif-thumbnailer


These are very useful utilities to have when working with heif files and they also help solve a dependency issue. If you are building software which you want to be able to convert these images to formats that can be viewed in a browser, they need to be .e.g, JPEGs. The common tools available to do these conversions are heif-convert, ImageMagick/GraphicsMagick, and vips. Unfortunately most OSes/packagers don't link their ImageMagick against libheif and vips is rather heavy. Vips also doesn't support heif until version 8.8 which is new enough to have missed the cut for Debian Stable.

It would be nice to have these packaged and available in FreeBSD.
Comment 1 Mark Felder freebsd_committer 2021-02-20 20:15:31 UTC
Created attachment 222688 [details]
fixed
Comment 2 Fernando Apesteguía freebsd_committer 2021-02-22 12:48:02 UTC
^Triage: Reporter is committer, assign accordingly.

^Triage: [tags] in issue Titles are deprecated.

^Triage: Simplifying title

Thanks!
Comment 3 Mark Felder freebsd_committer 2021-03-23 22:23:43 UTC

*** This bug has been marked as a duplicate of bug 245387 ***