Bug 254620 - www/minio rc.d script
Summary: www/minio rc.d script
Status: New
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Steve Wills
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-03-28 00:21 UTC by me
Modified: 2021-03-28 00:21 UTC (History)
0 users

See Also:
bugzilla: maintainer-feedback? (swills)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description me 2021-03-28 00:21:01 UTC
Service script /usr/local/etc/rc.d/minio needs a REQUIRE line at the top.  
  
I run minio in a jail and when the jail is restarted, minio does not start due to the network not being available until later in the process.  In my specific case, my jails use VNET with synchronous DHCP.  Once the jail is running, I shell into it and start it manually.
  
I haven't fully investigated yet, so not sure what exactly is required, but using "# REQUIRE: DAEMON NETWORKING" worked.