Bug 255069 - net.link.ether.ipfw=1 leads to kernel panic under 13.0-RELEASE amd64
Summary: net.link.ether.ipfw=1 leads to kernel panic under 13.0-RELEASE amd64
Status: New
Alias: None
Product: Base System
Classification: Unclassified
Component: kern (show other bugs)
Version: 13.0-STABLE
Hardware: amd64 Any
: --- Affects Some People
Assignee: freebsd-net (Nobody)
URL:
Keywords: panic, regression
Depends on:
Blocks:
 
Reported: 2021-04-14 22:13 UTC by Niels Bakker
Modified: 2021-04-16 08:50 UTC (History)
4 users (show)

See Also:


Attachments
/var/crash/core.txt.5 scrubbed of private information like IPs, MACs (116.43 KB, text/plain)
2021-04-14 22:13 UTC, Niels Bakker
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Niels Bakker 2021-04-14 22:13:38 UTC
Created attachment 224119 [details]
/var/crash/core.txt.5 scrubbed of private information like IPs, MACs

Upgrading from 12.2-RELEASE-p4 to 13.0-RELEASE made the kernel crash minutes after boot if /etc/sysctl.conf contained the line "net.link.ether.ipfw=1". No ipfw rule has a layer2 clause. Before the kernel panic there may be several SIGSEGV's of other processes.
Comment 1 Daniel Austin 2021-04-15 18:23:54 UTC
I can confirm that I have seen this behaviour too (disabling net.link.ether.ipfw fixes this) - I didn't get a coredump though so was hard to debug.
Comment 2 Daniel Austin 2021-04-15 18:29:14 UTC
not sure if it's helpful but... i tried enabling net.link.ether.ipfw=1 a few minutes after things had booted and settled which caused my networking to stop after about 20-30 seconds, and bge0 to watchdog timeout and reset repeatedly (never recovering until a reboot)

My setup is a HP Microserver Gen8 using the onboard bge0/1 NICs, generic kernel, ipfw (with nat), pppoe on bge1.
Comment 3 Andrey V. Elsukov freebsd_committer 2021-04-16 08:50:36 UTC
I tried to enable it on my notebook with 14.0-CURRENT, it doesn't panic, but something bad happened - XFCE partially hanged. I'll try to debug this at this weekend.