Bug 255151 - mail/rss2email3: update to v3.12.3 to fix breakage from textproc/py-feedparser update
Summary: mail/rss2email3: update to v3.12.3 to fix breakage from textproc/py-feedparse...
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Sofian Brabez
URL: https://github.com/rss2email/rss2emai...
Keywords:
Depends on:
Blocks:
 
Reported: 2021-04-17 14:51 UTC by Michael Büker
Modified: 2021-04-19 11:29 UTC (History)
2 users (show)

See Also:
chalpin: maintainer-feedback+


Attachments
ports tree patch for version update and dependency versions (1.38 KB, patch)
2021-04-17 14:51 UTC, Michael Büker
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Büker 2021-04-17 14:51:19 UTC
Created attachment 224188 [details]
ports tree patch for version update and dependency versions

The upgrade of textproc/py-feedparser to 6.0.x has broken mail/rss2email3, but the problem is fixed in version 3.12.3 of rss2email.

The attached patch also changes some dependency version requirements to correspond with upstream.
Comment 1 Sofian Brabez freebsd_committer 2021-04-17 15:26:57 UTC
Hi,

Correct, it was because of the limitation of 3.12.3 version of mail/rss2email3 in setup.py 'feedparser>=5.0.1, <6.0' cf. [1]. That software was not supported with the new version > 6.0. Glad it does now with 3.13 [2]

I'll take it.

[1] https://github.com/rss2email/rss2email/blob/v3.12.3/setup.py#L69
[2] https://github.com/rss2email/rss2email/blob/v3.13/setup.py#L69
Comment 2 Corey Halpin 2021-04-18 15:30:03 UTC
Comment on attachment 224188 [details]
ports tree patch for version update and dependency versions

Looks good to me, builds correctly in poudriere, built package works when installed. I approve this patch. Thank you!
Comment 3 Sofian Brabez freebsd_committer 2021-04-19 11:29:38 UTC
Hi,

It's committed, it doesn't appear because I wrongly set the PR ID, you can see the comment in the other ticket [1] and on cgit [2]. Thank you both.

[1] https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=224188#c2
[2] https://cgit.freebsd.org/ports/commit/?id=1ca64f5a13d6ea6897fa6a08e43f90239d89a8d5