Bug 255623 - devel/SpecTcl: fixes BROKEN, adds LICENSE, takes MAINTAINER
Summary: devel/SpecTcl: fixes BROKEN, adds LICENSE, takes MAINTAINER
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Li-Wen Hsu
URL:
Keywords: dogfood, easy, patch, patch-ready
Depends on:
Blocks:
 
Reported: 2021-05-05 17:16 UTC by Chris Hutchinson
Modified: 2021-05-11 13:36 UTC (History)
1 user (show)

See Also:


Attachments
patch for devel/SpecTcl (580 bytes, patch)
2021-05-05 17:16 UTC, Chris Hutchinson
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Hutchinson 2021-05-05 17:16:42 UTC
Created attachment 224697 [details]
patch for devel/SpecTcl

This port is currently marked BROKEN for
USES= tk:85

The attached patch ( diff(1) ) removes that
restriction. It further adds LICENSE and
changes MAINTAINER to me.

Builds/Works as intended.

Changes
Makefile
MAINTAINER (changes to me)
USES       (changes)
LICENSE    (adds)

That's it! :-)

Thanks!

NOTE: port is currently maintained by ports@ so approval is implicit.
Comment 1 commit-hook freebsd_committer 2021-05-11 13:36:14 UTC
A commit in branch main references this bug:

URL: https://cgit.FreeBSD.org/ports/commit/?id=4d3ecb3b8b4598b5152a2b54bcdb6d0700ca0484

commit 4d3ecb3b8b4598b5152a2b54bcdb6d0700ca0484
Author:     Chris Hutchinson <portmaster@bsdforge.com>
AuthorDate: 2021-05-11 13:34:58 +0000
Commit:     Li-Wen Hsu <lwhsu@FreeBSD.org>
CommitDate: 2021-05-11 13:35:36 +0000

    devel/SpecTcl: fixes BROKEN, adds LICENSE, takes MAINTAINER

    PR:             255623

 devel/SpecTcl/Makefile | 11 ++++++++---
 1 file changed, 8 insertions(+), 3 deletions(-)
Comment 2 Li-Wen Hsu freebsd_committer 2021-05-11 13:36:48 UTC
Committed, with some minor modifications to pet portlint(1)