Bug 255643 - net-p2p/jackett: Upgrade dependency to mono6.8
Summary: net-p2p/jackett: Upgrade dependency to mono6.8
Status: Closed DUPLICATE of bug 198727
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: amd64 Any
: --- Affects Only Me
Assignee: freebsd-ports-bugs (Nobody)
URL:
Keywords:
Depends on: 238089
Blocks:
  Show dependency treegraph
 
Reported: 2021-05-06 00:19 UTC by e62gkuad8
Modified: 2021-05-08 17:41 UTC (History)
3 users (show)

See Also:
bugzilla: maintainer-feedback? (michiel)


Attachments
excerpt of jacket.log (1.42 KB, text/plain)
2021-05-06 00:19 UTC, e62gkuad8
no flags Details
update jackett ports to require mono 6.8 (673 bytes, patch)
2021-05-07 03:22 UTC, e62gkuad8
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description e62gkuad8 2021-05-06 00:19:46 UTC
Created attachment 224715 [details]
excerpt of jacket.log

Request:

Please upgrade the port to use the mono6.8 runtime, the upstream appears to consider this a requirement.

See https://github.com/Jackett/Jackett/issues/10908

The current package requires mono which makes co-installing or upgrading the runtime not possible:

Installed packages to be REMOVED:
        mono6.8: 6.8.0.123

New packages to be INSTALLED:
        jackett: 0.17.568_1
        mono: 5.10.1.57_3


Issue:

jackett crashes on start, leave error message `System.IO.IOException: kevent() error at initial event registration, error code = '22'` in logs.


Platform:
FreeBSD 13.0-RELEASE amd64
jackett 0.17.568_1


Thank you
Comment 1 e62gkuad8 2021-05-06 03:14:13 UTC
I just came across the discussion on #238089, looks like the biggest blocker is figuring how to specify one mono runtime over another during install.
Comment 2 Michiel van Baak 2021-05-06 09:47:24 UTC
Yes, this is a know issue. See https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=198727

It's also the reason why every update to jackett states: works on 11.4 only.
The mono port is getting some new attention, so let's hope we can soon pick one in an easy way.
Comment 3 Daniel Ebdrup Jensen freebsd_committer 2021-05-06 10:01:16 UTC
Closing this at the request of the maintainer of the port, via IRC in #freebsd-bugs on FreeNode.

*** This bug has been marked as a duplicate of bug 198727 ***
Comment 4 e62gkuad8 2021-05-07 03:22:56 UTC
Created attachment 224743 [details]
update jackett ports to require mono 6.8

@Michiel, I know this issue was marked as a duplicate but I didn't want to add this to the other ticket since that's specific to the kqueue issue in Mono. The attached patch is how I addressed jackett's mono 6.8 runtime dependency.

I removed the build dependency and changed it to a runtime dependency on mono6.8.

I'm not a ports person, so I don't know if this is "correct" but it is what got it working for me. It cleanly installs with mono6.8 and runs.
Comment 5 Michiel van Baak 2021-05-07 16:59:50 UTC
(In reply to e62gkuad8 from comment #4)

I have a patch in that direction already in my tree.
Testing now with all 3 mono versions (where we already know that jackett+mono5.10 only works on FreeBSD < 12)

The only *problem* for now will be that you wont be able to install jackett and say, radarr, on the same machine/jail as the mono ports are conflicting eachother.
It will however make it possible for users to upgrade their jail from 11.4 to 12.2 or 13.0 ;P
Comment 6 e62gkuad8 2021-05-08 04:10:19 UTC
(In reply to Michiel van Baak from comment #5)

Okay cool, I'm glad to hear you have something already. I saw the comment here, https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=238089#c81 and was trying to make it work myself!

I was unfamiliar with radarr. Now that explains why one would likely be installed in the same jail. Now I'm more interested in becoming familiar :)

Thank you
Comment 7 Michiel van Baak 2021-05-08 17:41:01 UTC
(In reply to e62gkuad8 from comment #6)
For your info: https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=255710