Bug 256235 - deskutils/gnome-todo: fetch fails - wrong path (other gnome 40.* updates affected as well)
Summary: deskutils/gnome-todo: fetch fails - wrong path (other gnome 40.* updates affe...
Status: Closed DUPLICATE of bug 256202
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: freebsd-gnome (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-05-29 07:15 UTC by John Hein
Modified: 2021-05-29 14:22 UTC (History)
3 users (show)

See Also:
bugzilla: maintainer-feedback? (gnome)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description John Hein 2021-05-29 07:15:36 UTC
=> gnome-todo-40.0.tar.xz doesn't seem to exist in /usr/ports/distfiles/gnome3.
=> Attempting to fetch https://download.gnome.org/sources/gnome-todo/40.0/gnome-todo-40.0.tar.xz
fetch: https://download.gnome.org/sources/gnome-todo/40.0/gnome-todo-40.0.tar.xz: Not Found
=> Attempting to fetch http://download.gnome.org/sources/gnome-todo/40.0/gnome-todo-40.0.tar.xz
fetch: http://download.gnome.org/sources/gnome-todo/40.0/gnome-todo-40.0.tar.xz: Not Found


Upstream location is https://download.gnome.org/sources/gnome-todo/40  (not .../40.0).

Possible patch:

=======================

diff --git a/deskutils/gnome-todo/Makefile b/deskutils/gnome-todo/Makefile
index 236f210eb7ca..a4e16e040ae4 100644
--- a/deskutils/gnome-todo/Makefile
+++ b/deskutils/gnome-todo/Makefile
@@ -4,6 +4,7 @@ PORTNAME=       gnome-todo
 PORTVERSION=   40.0
 CATEGORIES=    deskutils gnome
 MASTER_SITES=  GNOME
+MASTER_SITE_SUBDIR=    sources/${PORTNAME}/${PORTVERSION:C/^([0-9]+)\..*/\1/}
 DIST_SUBDIR=   gnome3
 
 MAINTAINER=    gnome@FreeBSD.org


=======================


p.s. portlint gives:

WARN: Makefile: "USES" has to appear earlier.
Comment 1 John Hein 2021-05-29 07:16:22 UTC
CC'd committer.
Comment 2 John Hein 2021-05-29 14:01:49 UTC
More gnome ports that were updated to 40.* are not fetching either (graphics/eog, editors/gedit, ...).

A recent change to Mk/bsd.sites.mk to address this [1] has been reverted [2], but not all the port updates to 40.* who needed the change were reverted.  So now fetches are broken for all of them.

This seems like a bit of a mess which started because of not following procedures.  I don't see any references to discussions, reviews or PRs for any of these commits (including the various updates to individual gnome/glib ports).

[1] See commit 7eacfa59f9ec5a9f60a492586b0ac201dc0c8cc5 - the bsd.sites.mk part was a "sneak attack" commit that was not documented.  It probably should have been a separate commit (and was committed without approval [2]).

[2] See commit d6ab5eccc3e393be11900b5565888bc5d0da9612.  This reverted the bsd.sites.mk part of [1], and so now all the gnome 40.* updates that occurred after [1] have broken fetches as a result.
Comment 3 Mathieu Arnold freebsd_committer 2021-05-29 14:11:30 UTC
The correct way to fix this *in a port* is by writing:

 MASTER_SITES=  GNOME/sources/${PORTNAME}/${PORTVERSION:C/^([0-9]+)\..*/\1/}

Never use MASTER_SITE_SUBDIR.
Comment 4 John Hein 2021-05-29 14:22:37 UTC
(In reply to Mathieu Arnold from comment #3)
Yes, thanks.

This is a duplicate anyway.  My narrow search didn't find any of the similar bugs, and now addressed in https://reviews.freebsd.org/D30514

*** This bug has been marked as a duplicate of bug 256202 ***