Bug 256622 - devel/rubygem-inspec-core: Broken rubyzip dependency
Summary: devel/rubygem-inspec-core: Broken rubyzip dependency
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Matthias Fechner
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-06-15 18:08 UTC by Krzysztof Galazka
Modified: 2021-08-08 13:45 UTC (History)
2 users (show)

See Also:
bugzilla: maintainer-feedback? (ruby)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Krzysztof Galazka 2021-06-15 18:08:28 UTC
Gemspec adds dependency on rubyzip verion 1.2, which is not available:

       s.add_runtime_dependency(%q<rubyzip>.freeze, ["~> 1.2", ">= 1.2.2"])

Trying to use the gem ends with error message:

Unable to activate inspec-core-4.24.8, because rubyzip-2.3.0 conflicts with rubyzip (~> 1.2, >= 1.2.2)

It was updated in upstream to: ">= 1.2.2", "< 3.0"

https://github.com/inspec/inspec/commit/fe9a1c8dd5f76a5d4c17be806d8a2ebc5fd7f0f3
Comment 1 Pavel Merdin 2021-08-07 17:14:05 UTC
I wonder if there are only two people on planet who use chef-client and freebsd.
Comment 2 Matthias Fechner freebsd_committer 2021-08-07 20:33:17 UTC
It is using rubyzip 1.3:
rubygem-rubyzip13>=1.2.2<2:archivers/rubygem-rubyzip13 \

Are you sure you use version 4.24.8_1?
Comment 3 Pavel Merdin 2021-08-07 21:46:55 UTC
# pkg info | grep inspec
rubygem-inspec-core-4.24.8_1

The problem is not with pkg (freebsd) dependencies. The error message comes from gem package management. It does not like (and it's right) that two different gem packages need different version of the same rubyzip.
Comment 4 Pavel Merdin 2021-08-07 21:48:22 UTC
(In reply to Pavel Merdin from comment #3)
Even changing "~> 1.2" to "> 1.2" in the gemspec file for rubygem-inspec-core helps.
Comment 5 Matthias Fechner freebsd_committer 2021-08-08 05:11:09 UTC
Which package you have installed and you execute to see this problem?
Comment 6 Pavel Merdin 2021-08-08 10:52:46 UTC
(In reply to Matthias Fechner from comment #5)
The package is rubygem-chef-bin
The executable is chef-client
Comment 7 commit-hook freebsd_committer 2021-08-08 13:26:24 UTC
A commit in branch main references this bug:

URL: https://cgit.FreeBSD.org/ports/commit/?id=2d502fe195ef964f57639f998854667323905ccc

commit 2d502fe195ef964f57639f998854667323905ccc
Author:     Matthias Fechner <mfechner@FreeBSD.org>
AuthorDate: 2021-08-08 13:21:28 +0000
Commit:     Matthias Fechner <mfechner@FreeBSD.org>
CommitDate: 2021-08-08 13:25:37 +0000

    devel/rubygem-inspec-core: Update to 4.38.9

    This commit adds a new port www/rubygem-faraday14 copied from www/rubygem-faraday
    and modified to match version 1.4.
    This fixes a runtime error for chef-client (includes also problems
    with rubygem-zip).

    PR:             256622

 devel/rubygem-inspec-core/Makefile                 | 16 ++++++-------
 devel/rubygem-inspec-core/distinfo                 |  6 ++---
 .../files/patch-inspec-core.gemspec (gone)         | 20 ----------------
 www/Makefile                                       |  1 +
 www/rubygem-faraday14/Makefile (new)               | 28 ++++++++++++++++++++++
 www/rubygem-faraday14/distinfo (new)               |  3 +++
 www/rubygem-faraday14/pkg-descr (new)              |  5 ++++
 7 files changed, 48 insertions(+), 31 deletions(-)
Comment 8 Matthias Fechner freebsd_committer 2021-08-08 13:27:06 UTC
Should be fixed now, thanks for the report and the help to reproduce it!
Comment 9 Pavel Merdin 2021-08-08 13:45:26 UTC
(In reply to Matthias Fechner from comment #8)
That was quick. Thank you.
Will test it when the ports are updated.