Bug 256659 - ports-mgmt/poudriere-devel: creates broken i386 jails which are partially 64-bit
Summary: ports-mgmt/poudriere-devel: creates broken i386 jails which are partially 64-bit
Status: Closed DUPLICATE of bug 256652
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: amd64 Any
: --- Affects Some People
Assignee: Bryan Drewery
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-06-17 02:21 UTC by Victor Sudakov
Modified: 2021-06-17 19:51 UTC (History)
2 users (show)

See Also:
bugzilla: maintainer-feedback? (bdrewery)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Victor Sudakov 2021-06-17 02:21:13 UTC
When I create an i386 jail on a 12.2 amd64 system, the resulting jail is partially 32-bit and partially 64-bit, so its useless for package building, any 
"poudriere bulk" command ends with a bunch of errors.

How to reproduce:

poudriere jail -m ftp -c -j 122i386 -a i386 -v 12.2-RELEASE
[downloading, extracting and updating the jail]
find /poudriere/jails/122i386/{bin,sbin,usr/bin,usr/sbin,usr/lib} |\
  xargs file | grep "64-bit LSB" | wc -l

The above will find 13 64-bit binaries: /poudriere/jails/122i386/usr/lib/libssl.so.111 and others. The rest are 32-bit binaries (1034 binaries)

FREEBSD_HOST=ftp://ftp.freebsd.org in poudriere.conf

I suspect the problem is somewhere in the code where binary updates are applied to the jails.
Comment 1 Victor Sudakov 2021-06-17 02:25:12 UTC
It must be related to https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=256652
Comment 2 Bryan Drewery freebsd_committer 2021-06-17 19:51:07 UTC
Yup that's probably it. Thanks. Will handle in that one.

*** This bug has been marked as a duplicate of bug 256652 ***