Bug 257107 - emulators/wine-proton: Fails to install (32-bit Wine) for package repositories without i386 ABI enabled (pkg: wrong architecture: FreeBSD:14:amd64 instead of FreeBSD:14:i386)
Summary: emulators/wine-proton: Fails to install (32-bit Wine) for package repositorie...
Status: Closed Works As Intended
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Kubilay Kocak
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-07-11 11:12 UTC by Graham Perrin
Modified: 2021-08-12 02:24 UTC (History)
1 user (show)

See Also:
koobs: maintainer-feedback+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Graham Perrin 2021-07-11 11:12:00 UTC
% /usr/local/wine-proton/bin/winefile
/home/grahamperrin/.i386-wine-pkg//usr/local/wine-proton/bin/wine doesn't exist!

Try installing 32-bit wine with
        /usr/local/wine-proton/bin/pkg32.sh install wine-proton mesa-dri
% pkg info -x wine
i386-wine-5.0.4_1,1
wine-proton-6.3.2_1
% /usr/local/wine-proton/bin/pkg32.sh install wine-proton mesa-dri
pkg -o ABI=FreeBSD:14:i386 -o INSTALL_AS_USER=true -o RUN_SCRIPTS=false --rootdir /home/grahamperrin/.i386-wine-pkg install wine-proton mesa-dri
Updating FreeBSD repository catalogue...
Fetching meta.conf: 100%    163 B   0.2kB/s    00:01    
Fetching packagesite.txz: 100%    6 MiB   6.3MB/s    00:01    
pkg: cannot parse fingerprints: error while parsing <unknown>: line: 1, column: 0 - 'key must begin with a letter', character: '-'
Processing entries: 100%
FreeBSD repository update completed. 30093 packages processed.
Updating poudriere repository catalogue...
Fetching meta.conf: 100%    163 B   0.2kB/s    00:01    
Fetching packagesite.txz: 100%    1 KiB   1.3kB/s    00:01    
Processing entries:   0%
pkg: wrong architecture: FreeBSD:14:amd64 instead of FreeBSD:14:i386
pkg: repository poudriere contains packages with wrong ABI: FreeBSD:14:amd64
Processing entries: 100%
Unable to update repository poudriere
Error updating repositories!
% sudo /usr/local/wine-proton/bin/pkg32.sh install wine-proton mesa-dri
grahamperrin's password:
Don't run this script as root!
%
Comment 1 Alex S 2021-07-11 11:51:58 UTC
(In reply to Graham Perrin from comment #0)

> pkg: cannot parse fingerprints: error while parsing <unknown>: line: 1, column: 0 - 'key must begin with a letter', character: '-'

No idea.

> Updating poudriere repository catalogue...
...
> pkg: wrong architecture: FreeBSD:14:amd64 instead of FreeBSD:14:i386
> pkg: repository poudriere contains packages with wrong ABI: FreeBSD:14:amd64
...
> Unable to update repository poudriere

You should either (temporary) disable that repo or set up i386 Poudriere repo. There is nothing I can do to work around this.
Comment 2 Graham Perrin 2021-07-11 18:07:49 UTC
(In reply to Alex S from comment #1)

Thanks. Success: 

sudo uclcmd set --json --file /usr/local/etc/pkg/repos/poudriere.conf poudriere.enabled false

/usr/local/wine-proton/bin/pkg32.sh install wine-proton mesa-dri

sudo uclcmd set --json --file /usr/local/etc/pkg/repos/poudriere.conf poudriere.enabled true

----

Bug 254434 is for the fingerprints aspect; apparently negligible in the context of this bug 257107. 

----

Close as not a bug?
Comment 3 Kubilay Kocak freebsd_committer freebsd_triage 2021-08-11 00:56:51 UTC
Is there a change/improvement/fix to be made here?
Comment 4 Alex S 2021-08-11 01:28:41 UTC
(In reply to Kubilay Kocak from comment #3)

No, I just don't have the [Bugzilla] permission to close it.
Comment 5 Kubilay Kocak freebsd_committer freebsd_triage 2021-08-11 02:07:26 UTC
(In reply to Alex S from comment #4)

Thanks Alex, what is the correct resolution?
Comment 6 Alex S 2021-08-11 08:55:36 UTC
(In reply to Kubilay Kocak from comment #5)

The problem there is that `pkg -o ABI=FreeBSD:14:i386` command works only if all configured repos have i386 variants. This works very well with official repos, but if you have a custom Poudriere amd64-only repo, you'll get this update error (even if you don't intend to install any wine packages from it). So, depending on the perspective, this not a bug or at least not our bug (the proper place to complain about pkg limitations would be the pkg issue tracker), thus the resolution should be either invalid or wontfix.
Comment 7 Kubilay Kocak freebsd_committer freebsd_triage 2021-08-12 02:21:52 UTC
Thank you for the detail Alex. I've adjusted the Summary accordingly. If there is a potential improvement to be made on the pkg side of things, and an issue is reported in either of those upstreams, please include a See Also: reference here
Comment 8 Kubilay Kocak freebsd_committer freebsd_triage 2021-08-12 02:24:09 UTC
Note: There was no change proposal (patch), so WONTFIX (Not Accepted) doesn't apply. Not A Bug is potentially closer, but unless we acknowledge it 'as' a bug, Works As Intended (expected, in the circumstances) is slightly more accurate.