Bug 257191 (cmake-3.21.0) - [exp-run] Update cmake to 3.21.0
Summary: [exp-run] Update cmake to 3.21.0
Status: Closed FIXED
Alias: cmake-3.21.0
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Tobias C. Berner
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-07-14 17:56 UTC by Tobias C. Berner
Modified: 2021-07-29 08:04 UTC (History)
2 users (show)

See Also:
tcberner: exp-run?


Attachments
v1 (20.21 KB, patch)
2021-07-14 17:56 UTC, Tobias C. Berner
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Tobias C. Berner freebsd_committer 2021-07-14 17:56:16 UTC
Created attachment 226469 [details]
v1

Moin moin 

kde@ would like to ask for an exp-run to update devel/cmake* to 3.21.0.

The patch is attached, and can also be found here:

https://people.freebsd.org/~tcberner/patches/0001-devel-cmake-update-to-3.21.0.patch


mfg Tobias
Comment 2 commit-hook freebsd_committer 2021-07-21 09:28:12 UTC
A commit in branch main references this bug:

URL: https://cgit.FreeBSD.org/ports/commit/?id=67dc4be0e1f5bcb841c206cc63a7660a7e3d9181

commit 67dc4be0e1f5bcb841c206cc63a7660a7e3d9181
Author:     Tobias C. Berner <tcberner@FreeBSD.org>
AuthorDate: 2021-07-21 09:26:33 +0000
Commit:     Tobias C. Berner <tcberner@FreeBSD.org>
CommitDate: 2021-07-21 09:26:33 +0000

    math/wxmaxima: fix NLS=on handling

    The patch file removing the locales-subdirectory in cmake should
    was removed unconditionally, instead of only when NLS=off

    This came out of the cmake-3.21 exp-run but is unrelated to cmake.

    PR:             257191

 math/wxmaxima/files/{patch-CMakeLists.txt => extra-patch-CMakeLists.txt} | 0
 1 file changed, 0 insertions(+), 0 deletions(-)
Comment 3 Tobias C. Berner freebsd_committer 2021-07-21 09:39:51 UTC
* devel/elf-dissector is an issue with FreeBSD 12 only (unrelated to cmake)
* devel/kms-cmake-utils is the usual missed bump in its PLIST_SUB on major updates -- easily fixed when commiting 

Todo:
* astro/siril -- investigate missing static library
Comment 4 Adriaan de Groot freebsd_committer 2021-07-26 21:48:10 UTC
I am investigating astro/siril.
Comment 5 Tobias C. Berner freebsd_committer 2021-07-27 11:04:48 UTC
(In reply to Adriaan de Groot from comment #4)
astro/siril was caused by the meson update which was also part of the exp-run.

See [1] and [2] for the details.

[1] https://github.com/mesonbuild/meson/commit/0d0f2cdafd7597ff84baf7a4790f3f016fe2337f
[2] https://github.com/mesonbuild/meson/issues/8955


@antoine, this should address all the cmake-related issues.
Comment 6 Antoine Brodin freebsd_committer 2021-07-29 07:08:02 UTC
(In reply to Tobias C. Berner from comment #5)
If you have fixes for devel/kms-cmake-utils and graphics/darktable then this is fine
Comment 7 commit-hook freebsd_committer 2021-07-29 08:03:14 UTC
A commit in branch main references this bug:

URL: https://cgit.FreeBSD.org/ports/commit/?id=dd46273ab4a8daab2dd62a5764241c92cb14bcd8

commit dd46273ab4a8daab2dd62a5764241c92cb14bcd8
Author:     Tobias C. Berner <tcberner@FreeBSD.org>
AuthorDate: 2021-07-29 08:01:47 +0000
Commit:     Tobias C. Berner <tcberner@FreeBSD.org>
CommitDate: 2021-07-29 08:02:10 +0000

    devel/kms-cmake-utils: fix plist for cmake-3.21 release series

    PR:             257191

 devel/kms-cmake-utils/Makefile | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
Comment 8 commit-hook freebsd_committer 2021-07-29 08:03:15 UTC
A commit in branch main references this bug:

URL: https://cgit.FreeBSD.org/ports/commit/?id=10700b1eeb3ac87bdf7c44b829c30b69719b4424

commit 10700b1eeb3ac87bdf7c44b829c30b69719b4424
Author:     Tobias C. Berner <tcberner@FreeBSD.org>
AuthorDate: 2021-07-14 17:52:55 +0000
Commit:     Tobias C. Berner <tcberner@FreeBSD.org>
CommitDate: 2021-07-29 08:00:27 +0000

    devel/cmake: update to 3.21.0

    Release notes:
            https://cmake.org/cmake/help/v3.21/release/3.21.html

    PR:             257191
    Exp-run by:     antoine

 devel/cmake-doc/Makefile                         |  2 +-
 devel/cmake-gui/Makefile                         |  2 +-
 devel/cmake/Makefile                             |  2 +-
 devel/cmake/distinfo                             |  6 +--
 devel/cmake/files/patch-Modules_FindBoost.cmake  |  4 +-
 devel/cmake/files/patch-Modules_FindOpenMP.cmake | 14 ++---
 devel/cmake/pkg-plist                            | 68 +++++++++++++++++++++++-
 7 files changed, 82 insertions(+), 16 deletions(-)
Comment 9 commit-hook freebsd_committer 2021-07-29 08:03:16 UTC
A commit in branch main references this bug:

URL: https://cgit.FreeBSD.org/ports/commit/?id=346b0e795afbd973672e213dd310b9239ee7ff6c

commit 346b0e795afbd973672e213dd310b9239ee7ff6c
Author:     Tobias C. Berner <tcberner@FreeBSD.org>
AuthorDate: 2021-07-29 07:58:07 +0000
Commit:     Tobias C. Berner <tcberner@FreeBSD.org>
CommitDate: 2021-07-29 07:58:53 +0000

    graphics/darktable: prepare for cmake-3.21 update

    Fix build against cmake-3.21: the ninja generator in 3.21 suffers a regression
    (see https://gitlab.kitware.com/cmake/cmake/-/issues/22487) appending an invalid
    "-Wl,--no-as-needed" to the linker arguments for static libraries.
    Once this regression has been fixed upstream, this can be switch back to USES=cmake

    PR:             257191

 graphics/darktable/Makefile | 6 +++++-
 1 file changed, 5 insertions(+), 1 deletion(-)
Comment 10 Tobias C. Berner freebsd_committer 2021-07-29 08:04:07 UTC
Committed. Thanks for the exp-run.