Bug 257276 - math/wxmaxima: Fails to package: share/locale/*/LC_MESSAGES/wxMaxima.mo: No such file or directory (poudriere on stable/13), Fails to patch with NLS=OFF and
Summary: math/wxmaxima: Fails to package: share/locale/*/LC_MESSAGES/wxMaxima.mo: No s...
Status: Closed Unable to Reproduce
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: amd64 Any
: --- Affects Many People
Assignee: Li-Wen Hsu
URL:
Keywords: needs-patch, needs-qa
Depends on:
Blocks:
 
Reported: 2021-07-19 12:57 UTC by Robert Cina
Modified: 2021-07-28 01:07 UTC (History)
1 user (show)

See Also:
koobs: merge-quarterly?


Attachments
math/wxmaxima poudriere build log showing the build error (115.63 KB, text/plain)
2021-07-19 12:57 UTC, Robert Cina
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Robert Cina 2021-07-19 12:57:08 UTC
Created attachment 226547 [details]
math/wxmaxima poudriere build log showing the build error

The port math/wxmaxima fails to build for me while using poudriere on stable 13.

The following is the error I get from the build log:

===>  Building package for wxmaxima-20.04.0_2
pkg-static: Unable to access file /wrkdirs/usr/ports/math/wxmaxima/work/stage/usr/local/share/locale/ca/LC_MESSAGES/wxMaxima.mo:No such file or directory
pkg-static: Unable to access file /wrkdirs/usr/ports/math/wxmaxima/work/stage/usr/local/share/locale/cs/LC_MESSAGES/wxMaxima.mo:No such file or directory
pkg-static: Unable to access file /wrkdirs/usr/ports/math/wxmaxima/work/stage/usr/local/share/locale/da/LC_MESSAGES/wxMaxima.mo:No such file or directory
pkg-static: Unable to access file /wrkdirs/usr/ports/math/wxmaxima/work/stage/usr/local/share/locale/de/LC_MESSAGES/wxMaxima.mo:No such file or directory
pkg-static: Unable to access file /wrkdirs/usr/ports/math/wxmaxima/work/stage/usr/local/share/locale/el/LC_MESSAGES/wxMaxima.mo:No such file or directory
pkg-static: Unable to access file /wrkdirs/usr/ports/math/wxmaxima/work/stage/usr/local/share/locale/en/LC_MESSAGES/wxMaxima.mo:No such file or directory
pkg-static: Unable to access file /wrkdirs/usr/ports/math/wxmaxima/work/stage/usr/local/share/locale/es/LC_MESSAGES/wxMaxima.mo:No such file or directory
pkg-static: Unable to access file /wrkdirs/usr/ports/math/wxmaxima/work/stage/usr/local/share/locale/fi/LC_MESSAGES/wxMaxima.mo:No such file or directory
pkg-static: Unable to access file /wrkdirs/usr/ports/math/wxmaxima/work/stage/usr/local/share/locale/fr/LC_MESSAGES/wxMaxima.mo:No such file or directory
pkg-static: Unable to access file /wrkdirs/usr/ports/math/wxmaxima/work/stage/usr/local/share/locale/gl/LC_MESSAGES/wxMaxima.mo:No such file or directory
pkg-static: Unable to access file /wrkdirs/usr/ports/math/wxmaxima/work/stage/usr/local/share/locale/hu/LC_MESSAGES/wxMaxima.mo:No such file or directory
pkg-static: Unable to access file /wrkdirs/usr/ports/math/wxmaxima/work/stage/usr/local/share/locale/it/LC_MESSAGES/wxMaxima.mo:No such file or directory
pkg-static: Unable to access file /wrkdirs/usr/ports/math/wxmaxima/work/stage/usr/local/share/locale/ja/LC_MESSAGES/wxMaxima.mo:No such file or directory
pkg-static: Unable to access file /wrkdirs/usr/ports/math/wxmaxima/work/stage/usr/local/share/locale/kab/LC_MESSAGES/wxMaxima.mo:No such file or directory
pkg-static: Unable to access file /wrkdirs/usr/ports/math/wxmaxima/work/stage/usr/local/share/locale/nb/LC_MESSAGES/wxMaxima.mo:No such file or directory
pkg-static: Unable to access file /wrkdirs/usr/ports/math/wxmaxima/work/stage/usr/local/share/locale/pl/LC_MESSAGES/wxMaxima.mo:No such file or directory
pkg-static: Unable to access file /wrkdirs/usr/ports/math/wxmaxima/work/stage/usr/local/share/locale/pt_BR/LC_MESSAGES/wxMaxima.mo:No such file or directory
pkg-static: Unable to access file /wrkdirs/usr/ports/math/wxmaxima/work/stage/usr/local/share/locale/ru/LC_MESSAGES/wxMaxima.mo:No such file or directory
pkg-static: Unable to access file /wrkdirs/usr/ports/math/wxmaxima/work/stage/usr/local/share/locale/tr/LC_MESSAGES/wxMaxima.mo:No such file or directory
pkg-static: Unable to access file /wrkdirs/usr/ports/math/wxmaxima/work/stage/usr/local/share/locale/uk/LC_MESSAGES/wxMaxima.mo:No such file or directory
pkg-static: Unable to access file /wrkdirs/usr/ports/math/wxmaxima/work/stage/usr/local/share/locale/zh_CN/LC_MESSAGES/wxMaxima.mo:No such file or directory
pkg-static: Unable to access file /wrkdirs/usr/ports/math/wxmaxima/work/stage/usr/local/share/locale/zh_TW/LC_MESSAGES/wxMaxima.mo:No such file or directory
*** Error code 1

Stop.
make: stopped in /usr/ports/math/wxmaxima
=>> Cleaning up wrkdir
===>  Cleaning for wxmaxima-20.04.0_2
build of math/wxmaxima | wxmaxima-20.04.0_2 ended at Mon Jul 19 05:27:31 EDT 2021
build time: 00:00:50
!!! build failure encountered !!!
Comment 1 Kubilay Kocak freebsd_committer freebsd_triage 2021-07-20 04:09:28 UTC
Thank you for your report Robert. Is the issue still reproducible with NLS=OFF ?
Comment 2 Robert Cina 2021-07-20 12:40:37 UTC
Setting options without NLS support and building with poudriere causes the port to fail to build at the patch phase as follows:

More information about port maintainership is available at:

https://docs.freebsd.org/en/articles/contributing/#ports-contributing

===>  License GPLv2 accepted by the user
===> Fetching all distfiles required by wxmaxima-20.04.0_2 for building
===>  Extracting for wxmaxima-20.04.0_2
=> SHA256 Checksum OK for wxMaxima-Developers-wxmaxima-Version-20.04.0_GH0.tar.gz.
===========================================================================
=======================<phase: patch-depends  >============================
===========================================================================
=======================<phase: patch          >============================
===>  Patching for wxmaxima-20.04.0_2
===>  Applying extra patch /usr/ports/math/wxmaxima/files/extra-patch-CMakeLists.txt
cat: /usr/ports/math/wxmaxima/files/extra-patch-CMakeLists.txt: No such file or directory
===>  FAILED Applying extra patch /usr/ports/math/wxmaxima/files/extra-patch-CMakeLists.txt
*** Error code 1

Stop.
make: stopped in /usr/ports/math/wxmaxima
=>> Cleaning up wrkdir
===>  Cleaning for wxmaxima-20.04.0_2
build of math/wxmaxima | wxmaxima-20.04.0_2 ended at Tue Jul 20 08:36:59 EDT 2021
build time: 00:00:07
!!! build failure encountered !!!
 
Not sure why that happened. Anyways, thanks for the help trying to fix the issue.
Comment 3 Li-Wen Hsu freebsd_committer 2021-07-27 23:51:18 UTC
I cannot reproduce this issue.  Note this:

===>  Applying extra patch /usr/ports/math/wxmaxima/files/extra-patch-CMakeLists.txt
cat: /usr/ports/math/wxmaxima/files/extra-patch-CMakeLists.txt: No such file or directory

Please check if you have this file: /usr/ports/math/wxmaxima/files/extra-patch-CMakeLists.txt .  If no, please update the ports tree and try again.
Comment 4 Robert Cina 2021-07-28 00:05:40 UTC
That file /usr/ports/math/wxmaxima/files/extra-patch-CMakeLists.txt is present in the files directory. However, the port builds for me now using poudriere on stable 13 with and without NLS support and I don't have the error anymore.

I think this bug can be closed. Thanks.