Bug 257367 - lang/racket: update to 8.2
Summary: lang/racket: update to 8.2
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Jimmy Olgeni
URL: https://blog.racket-lang.org/2021/07/...
Keywords:
Depends on:
Blocks:
 
Reported: 2021-07-23 22:20 UTC by Philipp Ost
Modified: 2021-07-25 11:03 UTC (History)
0 users

See Also:
bugzilla: maintainer-feedback? (olgeni)


Attachments
Update lang/racket to version 8.2 (xz archive) (128.23 KB, application/x-xz)
2021-07-23 22:20 UTC, Philipp Ost
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Philipp Ost 2021-07-23 22:20:58 UTC
Created attachment 226645 [details]
Update lang/racket to version 8.2 (xz archive)

This patch updates lang/racket to version 8.2. It supersedes the work in Bug 257085.

Changes are as follows:
- add USES+=gmake
- remove MAKE_JOBS_UNSAFE
- introduce a single choice option which backend to build: BC or CS, where BC is the legacy byte code implementation and CS the newer one based on Chez Scheme. The FUTURES and JIT options are only allowed with BC=on. The --enable-libffi and --enable-places configure options where moved to the BC options, as the CS backend configure script does not provide these options.
- add a CHEZ_MACHTYPE which is currently only set for amd64, arm, arm64, i386 and powerpc (first introduced in Bug 255529)
- carry over the changes to the post-patch and post-install targets from Bug 255529
- add a patch to src/cs/c/configure to allow building on amd64

I also carried over the patch to src/bc/sconfig.h from Bug 255529 since I do not have access to FreeBSD machines with architectures other than amd64 and i386.

Although the patched port builds and (de)installs fine locally, it would be nice if someone could take a look a the pkg-plist. I am not quite sure if everything is in order.

Potential issue: stage-qa complains about possible REINPLACE_CMD issues:
/usr/ports/lang/racket/work/stage/usr/local/share/applications/drracket.desktop and /usr/ports/lang/racket/work/stage/usr/local/share/applications/slideshow.desktop are not modified.
I didn't yet look into the cause of this or how to fix this.
Comment 1 commit-hook freebsd_committer 2021-07-25 10:33:57 UTC
A commit in branch main references this bug:

URL: https://cgit.FreeBSD.org/ports/commit/?id=532f3ebe38bdc43fbaecf99de4bfaff92ebc7b23

commit 532f3ebe38bdc43fbaecf99de4bfaff92ebc7b23
Author:     Jimmy Olgeni <olgeni@FreeBSD.org>
AuthorDate: 2021-07-25 09:51:37 +0000
Commit:     Jimmy Olgeni <olgeni@FreeBSD.org>
CommitDate: 2021-07-25 09:51:37 +0000

    lang/racket-minimal: Update to version 8.2, with default ChezScheme support.

    (ported from e772c7109606)

    PR:             257367
    Reported by:    Philipp Ost <bsd@philippost.de>

 lang/racket-minimal/Makefile                       |   54 +-
 lang/racket-minimal/distinfo                       |    6 +-
 .../files/patch-src_bc_sconfig.h (new)             |   10 +
 .../files/patch-src_cs_c_configure (new)           |   11 +
 lang/racket-minimal/pkg-plist                      | 2568 ++++++++++----------
 5 files changed, 1367 insertions(+), 1282 deletions(-)
Comment 2 commit-hook freebsd_committer 2021-07-25 10:33:58 UTC
A commit in branch main references this bug:

URL: https://cgit.FreeBSD.org/ports/commit/?id=e772c7109606d234120ea01c556ec04758e3eda5

commit e772c7109606d234120ea01c556ec04758e3eda5
Author:     Jimmy Olgeni <olgeni@FreeBSD.org>
AuthorDate: 2021-07-25 09:48:14 +0000
Commit:     Jimmy Olgeni <olgeni@FreeBSD.org>
CommitDate: 2021-07-25 09:48:14 +0000

    lang/racket: Update to version 8.2, with default ChezScheme support.

    PR:             257367
    Reported by:    Philipp Ost <bsd@philippost.de>

 lang/racket/Makefile                             |    48 +-
 lang/racket/distinfo                             |     6 +-
 lang/racket/files/patch-src_bc_sconfig.h         |     8 +-
 lang/racket/files/patch-src_cs_c_configure (new) |    11 +
 lang/racket/pkg-plist                            | 24041 +++++++++++----------
 5 files changed, 12158 insertions(+), 11956 deletions(-)
Comment 3 Jimmy Olgeni freebsd_committer 2021-07-25 11:03:13 UTC
Patch committed and ported to racket-minimal.

The REINPLACE_CMD warnings seems to be about REINPLACE_CMD not actually changed the files; I rebuild everything without REINPLACE_CMD and the file contents look ok, so I removed it.

Thank you! \o/