A pool is not a zpool.
Avoid creating confusion around the command.
> Creating a ZFS storage pool (zpool) …
– should be:
> Creating a pool …
– and so on.
Please elaborate on why this is important.
It's simply wrong.
zpool is a command.
I recall (years ago, before I began using FreeBSD) when I first began learning about ZFS, it was sometimes horribly confusing where the word was misused to describe things other than the command.
"the storage zpool"; "a zpool"; "grow the zpool"; "zpool administration"; these phrases are wrong.
(It's as wrong as writing, for example, "grow the gpart".)
Just sticking my nose in here :-)
Whilst debian refers to them as zpools ( https://wiki.ubuntu.com/ZFS/ZPool ), it seems they are wrong too - Oracle/Sun refer to them as pools:
as does openzfs: https://openzfs.github.io/openzfs-docs/man/8/zpool-import.8.html